# CVE-2022-23525: Helm vulnerable to Denial of service via NULL Pointer Dereference

> Attackers can cause a denial of service in Helm by providing a malformed repository index file that triggers a null pointer dereference panic.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Dec 2022
- **Updated:** 18 Apr 2025
- **Also known as:** AZL-11655, BIT-helm-2022-23525, CLEANSTART-2026-SX42881, GHSA-53c4-hhmh-vw5q, GO-2022-1165, openSUSE-SU-2024:12603-1

## What is CVE-2022-23525?

CVE-2022-23525 is a medium-severity vulnerability in helm, published on 15 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Helm is a tool for managing Charts, pre-configured Kubernetes resources. Versions prior to 3.10.3 are subject to NULL Pointer Dereference in the _repo_package. The _repo_ package contains a handler that processes the index file of a repository. For example, the Helm client adds references to chart repositories where charts are managed. The _repo_ package parses the index file of the repository and loads it into structures Go can work with. Some index files can cause array data structures to be created causing a memory violation. Applications that use the _repo_ package in the Helm SDK to parse an index file can suffer a Denial of Service when that input causes a panic that cannot be recovered from. The Helm Client will panic with an index file that causes a memory violation panic. Helm is not a long running service so the panic will not affect future uses of the Helm client. This issue has been patched in 3.10.3. SDK users can validate index files that are correctly formatted before passing them to the _repo_ functions.

Weakness: CWE-476 (NULL Pointer Dereference)

## Which versions are affected by CVE-2022-23525?

4 open source packages ship an affected version, including helm.sh/helm/v3 and helm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `helm.sh/helm/v3` | Go | All versions | 3.10.3 |
| `helm.sh/helm/v3` | Go | All versions | 3.10.3 |
| `helm.sh/helm/v3` | Go | All versions | 3.10.3 |
| `helm` | Bitnami | From 3.0.0 | 3.10.3 |
| `cmctl` | openSUSE:Tumbleweed | All versions | 1.10.2-1.1 |

Products: Helm Helm.

## How do I fix CVE-2022-23525?

Upgrade helm.sh/helm/v3 to 3.10.3 or later.

## Is CVE-2022-23525 being exploited?

There is no known exploitation of CVE-2022-23525 in the wild and no public exploit code.

## Other vulnerabilities in helm

- [CVE-2019-18658](https://insights.sbomify.com/CVE-2019-18658/): Helm Unsafe Link Following (critical 9.8)
- [CVE-2019-1010275](https://insights.sbomify.com/CVE-2019-1010275/): Helm Improper Certificate Validation (critical 9.8)
- [CVE-2019-25210](https://insights.sbomify.com/CVE-2019-25210/): Information disclosure in n/a (critical 9.1)
- [CVE-2025-53547](https://insights.sbomify.com/CVE-2025-53547/): Helm Chart Dependency Updating With Malicious Chart.yaml Content And Symlink Can Lead To Code Execution (high 8.5)
- [CVE-2020-11013](https://insights.sbomify.com/CVE-2020-11013/): lookup Function Information Discolosure in Helm (high 8.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-23525 and fix it if it is affected.

What it is: CVE-2022-23525 is a medium-severity vulnerability in helm, published on 15 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-23525 in the wild and no public exploit code.

Affected packages and fixed versions:
- helm.sh/helm/v3 (Go): affected all versions; fixed in 3.10.3
- helm.sh/helm/v3 (Go): affected all versions; fixed in 3.10.3
- helm.sh/helm/v3 (Go): affected all versions; fixed in 3.10.3
- helm (Bitnami): affected from 3.0.0; fixed in 3.10.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-23525/ (Markdown: https://insights.sbomify.com/CVE-2022-23525/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-23525
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-23525
- OSV: https://osv.dev/vulnerability/CVE-2022-23525

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-23525/
Summaries are generated and may contain mistakes; the official description above is the record.
