{"answers":{"affected":"It affects 2 products.","exploited":"There is no known exploitation of CVE-2022-23527 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2022-23527 is a medium-severity vulnerability in Debian Debian Linux, published on 14 Dec 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-23527 and fix it if it is affected.\n\nWhat it is: CVE-2022-23527 is a medium-severity vulnerability in Debian Debian Linux, published on 14 Dec 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2022-23527 in the wild and no public exploit code.\n\nAffected product: Debian Debian Linux. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-23527/ (Markdown: https://insights.sbomify.com/CVE-2022-23527/index.md)","id":"CVE-2022-23527","markdown":"https://insights.sbomify.com/CVE-2022-23527/index.md","name":"CVE-2022-23527","record":{"aliases":["AZL-11653","CLSA-2025-1753800294","DEBIAN-CVE-2022-23527","GHSA-q6f2-285m-gr53","UBUNTU-CVE-2022-23527","openSUSE-SU-2024:12584-1"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache authentication module","requires_auth":"none","summary":"An attacker can redirect users to malicious sites via a crafted logout parameter in the mod_auth_openidc Apache module.","user_interaction":"required","vuln_class":"open_redirect"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"debian_linux","vendor":"debian"},{"product":"mod_auth_openidc","vendor":"openidc"}],"cvss":{"score":4.7,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-601","name":"URL Redirection to Untrusted Site"}],"description":"mod_auth_openidc is an OpenID Certified™ authentication and authorization module for the Apache 2.x HTTP server. Versions prior to 2.4.12.2 are vulnerable to Open Redirect. When providing a logout parameter to the redirect URI, the existing code in oidc_validate_redirect_url() does not properly check for URLs that start with /\\t, leading to an open redirect. This issue has been patched in version 2.4.12.2. Users unable to upgrade can mitigate the issue by configuring mod_auth_openidc to only allow redirection when the destination matches a given regular expression with OIDCRedirectURLsAllowed.","ecosystems":["openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Open Redirect in oidc_validate_redirect_url()","id":"CVE-2022-23527","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"debian:debian_linux","products":["debian:debian_linux"],"type":"open_redirect","year":"2022"},"n_packages":1,"n_references":3,"next":{"headline":"DO NOT USE THIS CANDIDATE NUMBER.","id":"CVE-2022-23529"},"packages":[{"ecosystem":"openSUSE:Tumbleweed","fixed":["2.4.12.2-1.1"],"introduced":["0"],"last_affected":[],"package":"apache2-mod_auth_openidc","purl":"pkg:rpm/opensuse/apache2-mod_auth_openidc\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:12584-1"}],"prev":{"headline":"Helm contains Denial of service through schema file","id":"CVE-2022-23526"},"products":["mod_auth_openidc"],"published":"2022-12-14","related":[{"cvss_score":10,"headline":"ProFTPD Improper Access Control","id":"CVE-2015-3306","kev_date_added":"2026-10-08","published":"2015-05-18"},{"cvss_score":9.9,"headline":"RoundCube Webmail Deserialization of Untrusted Data","id":"CVE-2025-49113","kev_date_added":"2026-02-20","published":"2025-06-02"},{"cvss_score":9.8,"headline":"GNU InetUtils Argument Injection","id":"CVE-2026-24061","kev_date_added":"2026-01-26","published":"2026-01-21"},{"cvss_score":9.8,"headline":"Linux Kernel Improper Check for Unusual or Exceptional Conditions","id":"CVE-2025-39682","kev_date_added":"2026-09-18","published":"2025-09-05"},{"cvss_score":9.8,"headline":"Mozilla Firefox Use-After-Free","id":"CVE-2024-9680","kev_date_added":"2024-10-15","published":"2024-10-09"},{"cvss_score":9.8,"headline":"RARLAB UnRAR Directory Traversal","id":"CVE-2022-30333","kev_date_added":"2022-08-09","published":"2022-05-09"},{"cvss_score":9.8,"headline":"Roundcube Webmail SQL Injection","id":"CVE-2021-44026","kev_date_added":"2023-06-22","published":"2021-11-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-18","vendors":["zmartzone"]},"summary":"An attacker can redirect users to malicious sites via a crafted logout parameter in the mod_auth_openidc Apache module.","url":"https://insights.sbomify.com/CVE-2022-23527/"}