# CVE-2022-23527: Open Redirect in oidc_validate_redirect_url()

> An attacker can redirect users to malicious sites via a crafted logout parameter in the mod_auth_openidc Apache module.

- **Severity:** Medium 4.7 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 14 Dec 2022
- **Updated:** 18 Apr 2025
- **Also known as:** AZL-11653, CLSA-2025-1753800294, DEBIAN-CVE-2022-23527, GHSA-q6f2-285m-gr53, UBUNTU-CVE-2022-23527, openSUSE-SU-2024:12584-1

## What is CVE-2022-23527?

CVE-2022-23527 is a medium-severity vulnerability in Debian Debian Linux, published on 14 Dec 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

mod_auth_openidc is an OpenID Certified™ authentication and authorization module for the Apache 2.x HTTP server. Versions prior to 2.4.12.2 are vulnerable to Open Redirect. When providing a logout parameter to the redirect URI, the existing code in oidc_validate_redirect_url() does not properly check for URLs that start with /\t, leading to an open redirect. This issue has been patched in version 2.4.12.2. Users unable to upgrade can mitigate the issue by configuring mod_auth_openidc to only allow redirection when the destination matches a given regular expression with OIDCRedirectURLsAllowed.

Weakness: CWE-601 (URL Redirection to Untrusted Site)

## Which versions are affected by CVE-2022-23527?

It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache2-mod_auth_openidc` | openSUSE:Tumbleweed | All versions | 2.4.12.2-1.1 |

Products: Debian Debian Linux, Openidc Mod Auth Openidc.

## How do I fix CVE-2022-23527?

Upgrade to a fixed version.

## Is CVE-2022-23527 being exploited?

There is no known exploitation of CVE-2022-23527 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-23527 and fix it if it is affected.

What it is: CVE-2022-23527 is a medium-severity vulnerability in Debian Debian Linux, published on 14 Dec 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-23527 in the wild and no public exploit code.

Affected product: Debian Debian Linux. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-23527/ (Markdown: https://insights.sbomify.com/CVE-2022-23527/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-23527
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-23527
- OSV: https://osv.dev/vulnerability/CVE-2022-23527

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-23527/
Summaries are generated and may contain mistakes; the official description above is the record.
