{"answers":{"affected":"2 open source packages ship an affected version, including LiteDB. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-23535 in the wild and no public exploit code.","fix":"Upgrade LiteDB to 5.0.13 or later.","what":"CVE-2022-23535 is a high-severity unsafe deserialization vulnerability in mbdavid LiteDB, published on 24 Feb 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-23535 and fix it if it is affected.\n\nWhat it is: CVE-2022-23535 is a high-severity unsafe deserialization vulnerability in mbdavid LiteDB, published on 24 Feb 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-23535 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- LiteDB (NuGet): affected all versions; fixed in 5.0.13\n- LiteDB (NuGet): affected all versions; fixed in 5.0.13\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-23535/ (Markdown: https://insights.sbomify.com/CVE-2022-23535/index.md)","id":"CVE-2022-23535","markdown":"https://insights.sbomify.com/CVE-2022-23535/index.md","name":"CVE-2022-23535","record":{"aliases":["GHSA-3x49-g6rc-c284"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":".NET NoSQL database","requires_auth":"none","summary":"An attacker can execute arbitrary code by sending malicious JSON to a LiteDB application that deserializes untrusted data into POCO classes.","user_interaction":"not_required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"litedb","vendor":"litedb"}],"cvss":{"score":7.3,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-502","name":"Deserialization of Untrusted Data"}],"description":"LiteDB is a small, fast and lightweight .NET NoSQL embedded database. Versions prior to 5.0.13 are subject to Deserialization of Untrusted Data. LiteDB uses a special field in JSON documents to cast different types from `BsonDocument` to POCO classes. When instances of an object are not the same of class, `BsonMapper` use a special field `_type` string info with full class name with assembly to be loaded and fit into your model. If your end-user can send to your app a plain JSON string, deserialization can load an unsafe  object to fit into your model. This issue is patched in version 5.0.13 with some basic fixes to avoid this, but is not 100% guaranteed when using `Object` type. The next major version will contain an allow-list to select what kind of Assembly can be loaded. Workarounds are detailed in the vendor advisory.","ecosystems":["NuGet"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"LiteDB contains Deserialization of Untrusted Data","id":"CVE-2022-23535","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"NuGet","product":null,"products":[],"type":"deserialization","year":"2022"},"n_packages":2,"n_references":2,"next":{"headline":"Alertmanager can expose local files content via specially crafted config","id":"CVE-2022-23536"},"packages":[{"ecosystem":"NuGet","fixed":["5.0.13"],"introduced":["0"],"last_affected":[],"package":"LiteDB","purl":null,"source":"GHSA-3x49-g6rc-c284"},{"ecosystem":"NuGet","fixed":["5.0.13"],"introduced":["0"],"last_affected":[],"package":"LiteDB","purl":"pkg:nuget/LiteDB","source":"GHSA-3x49-g6rc-c284"}],"prev":{"headline":"neo4j-apoc-procedures is vulnerable to path traversal","id":"CVE-2022-23532"},"products":["LiteDB"],"published":"2023-02-24","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-03-10","vendors":["mbdavid"]},"summary":"An attacker can execute arbitrary code by sending malicious JSON to a LiteDB application that deserializes untrusted data into POCO classes.","url":"https://insights.sbomify.com/CVE-2022-23535/"}