# CVE-2022-23535: LiteDB contains Deserialization of Untrusted Data

> An attacker can execute arbitrary code by sending malicious JSON to a LiteDB application that deserializes untrusted data into POCO classes.

- **Severity:** High 7.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Feb 2023
- **Updated:** 10 Mar 2025
- **Also known as:** GHSA-3x49-g6rc-c284

## What is CVE-2022-23535?

CVE-2022-23535 is a high-severity unsafe deserialization vulnerability in mbdavid LiteDB, published on 24 Feb 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

LiteDB is a small, fast and lightweight .NET NoSQL embedded database. Versions prior to 5.0.13 are subject to Deserialization of Untrusted Data. LiteDB uses a special field in JSON documents to cast different types from `BsonDocument` to POCO classes. When instances of an object are not the same of class, `BsonMapper` use a special field `_type` string info with full class name with assembly to be loaded and fit into your model. If your end-user can send to your app a plain JSON string, deserialization can load an unsafe  object to fit into your model. This issue is patched in version 5.0.13 with some basic fixes to avoid this, but is not 100% guaranteed when using `Object` type. The next major version will contain an allow-list to select what kind of Assembly can be loaded. Workarounds are detailed in the vendor advisory.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2022-23535?

2 open source packages ship an affected version, including LiteDB. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `LiteDB` | NuGet | All versions | 5.0.13 |
| `LiteDB` | NuGet | All versions | 5.0.13 |

Products: Litedb Litedb.

## How do I fix CVE-2022-23535?

Upgrade LiteDB to 5.0.13 or later.

## Is CVE-2022-23535 being exploited?

There is no known exploitation of CVE-2022-23535 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-23535 and fix it if it is affected.

What it is: CVE-2022-23535 is a high-severity unsafe deserialization vulnerability in mbdavid LiteDB, published on 24 Feb 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-23535 in the wild and no public exploit code.

Affected packages and fixed versions:
- LiteDB (NuGet): affected all versions; fixed in 5.0.13
- LiteDB (NuGet): affected all versions; fixed in 5.0.13

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-23535/ (Markdown: https://insights.sbomify.com/CVE-2022-23535/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-23535
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-23535
- OSV: https://osv.dev/vulnerability/CVE-2022-23535

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-23535/
Summaries are generated and may contain mistakes; the official description above is the record.
