CVE-2022-23542 OpenFGA Authorization Bypass

High 7.7 Published Updated

Attackers can bypass authorization checks in OpenFGA, potentially gaining unauthorized access to protected resources.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2022-23542?

CVE-2022-23542 is a high-severity authentication bypass vulnerability in openfga, published on 20 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

OpenFGA is an authorization/permission engine built for developers and inspired by Google Zanzibar. During an internal security assessment, it was discovered that OpenFGA version 0.3.0 is vulnerable to authorization bypass under certain conditions. This issue has been patched in version 0.3.1 and is backward compatible.

Weakness: CWE-285

Which versions are affected by CVE-2022-23542?

3 open source packages ship an affected version, including github.com/openfga/openfga. It affects 1 product.

PackageAffectedFixed in
github.com/openfga/openfga GoFrom 0.3.00.3.1
github.com/openfga/openfga GoFrom 0.3.00.3.1
github.com/openfga/openfga GoFrom 0.3.00.3.1

Products include Openfga Openfga.

How do I fix CVE-2022-23542?

Upgrade github.com/openfga/openfga to 0.3.1 or later.

Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.

Is CVE-2022-23542 being exploited?

There is no known exploitation of CVE-2022-23542 in the wild and no public exploit code.

Sources

Also known as GHSA-m3q4-7qmj-657m, GO-2022-1179.

Is CVE-2022-23542 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free