# CVE-2022-23542: OpenFGA Authorization Bypass

> Attackers can bypass authorization checks in OpenFGA, potentially gaining unauthorized access to protected resources.

- **Severity:** High 7.7 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Dec 2022
- **Updated:** 16 Apr 2025
- **Also known as:** GHSA-m3q4-7qmj-657m, GO-2022-1179

## What is CVE-2022-23542?

CVE-2022-23542 is a high-severity authentication bypass vulnerability in openfga, published on 20 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

OpenFGA is an authorization/permission engine built for developers and inspired by Google Zanzibar. During an internal security assessment, it was discovered that OpenFGA version 0.3.0 is vulnerable to authorization bypass under certain conditions. This issue has been patched in version 0.3.1 and is backward compatible.

Weakness: CWE-285 (Improper Authorization)

## Which versions are affected by CVE-2022-23542?

3 open source packages ship an affected version, including github.com/openfga/openfga. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/openfga/openfga` | Go | From 0.3.0 | 0.3.1 |
| `github.com/openfga/openfga` | Go | From 0.3.0 | 0.3.1 |
| `github.com/openfga/openfga` | Go | From 0.3.0 | 0.3.1 |

Products: Openfga Openfga.

## How do I fix CVE-2022-23542?

Upgrade github.com/openfga/openfga to 0.3.1 or later.

## Is CVE-2022-23542 being exploited?

There is no known exploitation of CVE-2022-23542 in the wild and no public exploit code.

## Other vulnerabilities in openfga

- [CVE-2024-31452](https://insights.sbomify.com/CVE-2024-31452/): OpenFGA Authorization Bypass (high 8.1)
- [CVE-2024-42473](https://insights.sbomify.com/CVE-2024-42473/): OpenFGA Authorization Bypass (high 7.5)
- [CVE-2026-40293](https://insights.sbomify.com/CVE-2026-40293/): OpenFGA Playground Preshared Key Exposure (medium 6.5)
- [CVE-2023-40579](https://insights.sbomify.com/CVE-2023-40579/): OpenFGA Authorization Bypass (medium 6.5)
- [CVE-2023-43645](https://insights.sbomify.com/CVE-2023-43645/): Denial of service from circular relationship definitions in OpenFGA (medium 5.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-23542 and fix it if it is affected.

What it is: CVE-2022-23542 is a high-severity authentication bypass vulnerability in openfga, published on 20 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-23542 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/openfga/openfga (Go): affected from 0.3.0; fixed in 0.3.1
- github.com/openfga/openfga (Go): affected from 0.3.0; fixed in 0.3.1
- github.com/openfga/openfga (Go): affected from 0.3.0; fixed in 0.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-23542/ (Markdown: https://insights.sbomify.com/CVE-2022-23542/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-23542
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-23542
- OSV: https://osv.dev/vulnerability/CVE-2022-23542

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-23542/
Summaries are generated and may contain mistakes; the official description above is the record.
