CVE-2022-23548 Denial of service in discourse

Medium 6.5 Published Updated

Attackers can cause denial of service in Discourse forums via regular expression denial of service attacks during post parsing.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2022-23548?

CVE-2022-23548 is a medium-severity denial of service vulnerability in Discourse Discourse, published on 5 Jan 2023. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Discourse is an option source discussion platform. Prior to version 2.8.14 on the `stable` branch and version 2.9.0.beta16 on the `beta` and `tests-passed` branches, parsing posts can be susceptible to regular expression denial of service (ReDoS) attacks. This issue is patched in versions 2.8.14 and 2.9.0.beta16. There are no known workarounds.

Weakness: CWE-1333

Which versions are affected by CVE-2022-23548?

1 open source package ship an affected version, including discourse. It affects 1 product.

PackageAffectedFixed in
discourse BitnamiAll versions2.8.14

Products include Discourse Discourse.

How do I fix CVE-2022-23548?

Upgrade discourse to 2.8.14 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2022-23548 being exploited?

There is no known exploitation of CVE-2022-23548 in the wild and no public exploit code.

All Discourse Discourse vulnerabilities

Sources

Also known as BIT-discourse-2022-23548, GHSA-7rw2-f4x7-7pxf.

Is CVE-2022-23548 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free