CVE-2022-23549 Discourse vulnerable to bypass of post max_length using HTML comments

Medium 5.7 Published Updated

Attackers can bypass post length restrictions by using HTML comments, allowing them to submit posts longer than the configured maximum limit.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2022-23549?

CVE-2022-23549 is a medium-severity vulnerability in Discourse Discourse, published on 5 Jan 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

Discourse is an option source discussion platform. Prior to version 2.8.14 on the `stable` branch and version 2.9.0.beta16 on the `beta` and `tests-passed` branches, users can create posts with raw body longer than the `max_length` site setting by including html comments that are not counted toward the character limit. This issue is patched in versions 2.8.14 and 2.9.0.beta16. There are no known workarounds.

Weakness: CWE-20

Which versions are affected by CVE-2022-23549?

1 open source package ship an affected version, including discourse. It affects 1 product.

PackageAffectedFixed in
discourse BitnamiAll versions2.8.14

Products include Discourse Discourse.

How do I fix CVE-2022-23549?

Upgrade discourse to 2.8.14 or later.

Is CVE-2022-23549 being exploited?

There is no known exploitation of CVE-2022-23549 in the wild and no public exploit code.

All Discourse Discourse vulnerabilities

Sources

Also known as BIT-discourse-2022-23549, GHSA-p47g-v5wr-p4xp.

Is CVE-2022-23549 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free