# CVE-2022-2355: Easy Username Updater < 1.0.5 - Arbitrary Username Update via CSRF

> Attackers can force logged-in admins to change any user's username, including their own, via CSRF in the Easy Username Updater plugin.

- **Severity:** Medium 5.7 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 8 Aug 2022
- **Updated:** 27 Aug 2025
- **Also known as:** GHSA-m4cf-jv4v-7jr7

## What is CVE-2022-2355?

CVE-2022-2355 is a medium-severity vulnerability in Unknown Easy Username Updater, published on 8 Aug 2022. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

The Easy Username Updater WordPress plugin before 1.0.5 does not implement CSRF checks, which could allow attackers to make a logged in admin change any user's username includes the admin

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2022-2355?

It affects 1 product.


Products: Easy Username Updater Project Easy Username Updater.

## How do I fix CVE-2022-2355?

No fix has been published for CVE-2022-2355 yet. Limit exposure of the affected software until one is available.

## Is CVE-2022-2355 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-2355 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-2355 and fix it if it is affected.

What it is: CVE-2022-2355 is a medium-severity vulnerability in Unknown Easy Username Updater, published on 8 Aug 2022. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-2355 exists.

Affected product: Unknown Easy Username Updater. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-2355/ (Markdown: https://insights.sbomify.com/CVE-2022-2355/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-2355
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-2355
- OSV: https://osv.dev/vulnerability/CVE-2022-2355

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-2355/
Summaries are generated and may contain mistakes; the official description above is the record.
