CVE-2022-23552 Grafana stored XSS in FileUploader component
An Editor can inject malicious JavaScript via SVG files in GeoMap panels, leading to privilege escalation when an Admin views the dashboard.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2022-23552?
CVE-2022-23552 is a high-severity cross-site scripting vulnerability in Grafana Grafana, published on 27 Jan 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
Grafana is an open-source platform for monitoring and observability. Starting with the 8.1 branch and prior to versions 8.5.16, 9.2.10, and 9.3.4, Grafana had a stored XSS vulnerability affecting the core plugin GeoMap. The stored XSS vulnerability was possible because SVG files weren't properly sanitized and allowed arbitrary JavaScript to be executed in the context of the currently authorized user of the Grafana instance.
An attacker needs to have the Editor role in order to change a panel to include either an external URL to a SVG-file containing JavaScript, or use the `data:` scheme to load an inline SVG-file containing JavaScript. This means that vertical privilege escalation is possible, where a user with Editor role can change to a known password for a user having Admin role if the user with Admin role executes malicious JavaScript viewing a dashboard.
Users may upgrade to version 8.5.16, 9.2.10, or 9.3.4 to receive a fix.
Weakness: CWE-79
Which versions are affected by CVE-2022-23552?
1 open source package ship an affected version, including grafana. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
grafana Bitnami | From 8.1.0 | 8.5.16, 9.2.10, 9.3.4 |
Products include Grafana Grafana.
How do I fix CVE-2022-23552?
Upgrade grafana to a fixed version for your release line: 8.5.16, 9.2.10 or 9.3.4.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2022-23552 being exploited?
There is no known exploitation of CVE-2022-23552 in the wild and no public exploit code.
Other vulnerabilities in Grafana Grafana
Sources
Also known as BIT-grafana-2022-23552, CLSA-2025-1757427057, GHSA-8xmm-x63g-f6xv, OESA-2025-2547, OESA-2025-2548, OESA-2025-2549 and 1 more.