# CVE-2022-23552: Grafana stored XSS in FileUploader component

> An Editor can inject malicious JavaScript via SVG files in GeoMap panels, leading to privilege escalation when an Admin views the dashboard.

- **Severity:** High 7.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 27 Jan 2023
- **Updated:** 28 Jan 2026
- **Also known as:** BIT-grafana-2022-23552, CLSA-2025-1757427057, GHSA-8xmm-x63g-f6xv, OESA-2025-2547, OESA-2025-2548, OESA-2025-2549, OESA-2025-2550

## What is CVE-2022-23552?

CVE-2022-23552 is a high-severity cross-site scripting vulnerability in Grafana Grafana, published on 27 Jan 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Grafana is an open-source platform for monitoring and observability. Starting with the 8.1 branch and prior to versions 8.5.16, 9.2.10, and 9.3.4, Grafana had a stored XSS vulnerability affecting the core plugin GeoMap. The stored XSS vulnerability was possible because SVG files weren't properly sanitized and allowed arbitrary JavaScript to be executed in the context of the currently authorized user of the Grafana instance. 

An attacker needs to have the Editor role in order to change a panel to include either an external URL to a SVG-file containing JavaScript, or use the `data:` scheme to load an inline SVG-file containing JavaScript. This means that vertical privilege escalation is possible, where a user with Editor role can change to a known password for a user having Admin role if the user with Admin role executes malicious JavaScript viewing a dashboard.   

Users may upgrade to version 8.5.16, 9.2.10, or 9.3.4 to receive a fix.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2022-23552?

1 open source package ship an affected version, including grafana. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `grafana` | Bitnami | From 8.1.0 | 8.5.16, 9.2.10, 9.3.4 |

Products: Grafana Grafana.

## How do I fix CVE-2022-23552?

Upgrade grafana to a fixed version for your release line: 8.5.16, 9.2.10 or 9.3.4.

## Is CVE-2022-23552 being exploited?

There is no known exploitation of CVE-2022-23552 in the wild and no public exploit code.

## Other vulnerabilities in Grafana Grafana

- [CVE-2021-43798](https://insights.sbomify.com/CVE-2021-43798/): Grafana Path Traversal (high 7.5, exploited in the wild)
- [CVE-2025-41115](https://insights.sbomify.com/CVE-2025-41115/): Incorrect privilege assignment (critical 10.0)
- [CVE-2022-39328](https://insights.sbomify.com/CVE-2022-39328/): Grafana vulnerable to race condition allowing privilege escalation (critical 9.8)
- [CVE-2022-28660](https://insights.sbomify.com/CVE-2022-28660/): Auth bypass in n/a (critical 9.8)
- [CVE-2022-26148](https://insights.sbomify.com/CVE-2022-26148/): Information disclosure in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-23552 and fix it if it is affected.

What it is: CVE-2022-23552 is a high-severity cross-site scripting vulnerability in Grafana Grafana, published on 27 Jan 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-23552 in the wild and no public exploit code.

Affected packages and fixed versions:
- grafana (Bitnami): affected from 8.1.0; fixed in 8.5.16, 9.2.10, 9.3.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-23552/ (Markdown: https://insights.sbomify.com/CVE-2022-23552/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-23552
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-23552
- OSV: https://osv.dev/vulnerability/CVE-2022-23552

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-23552/
Summaries are generated and may contain mistakes; the official description above is the record.
