# CVE-2022-23554: Authentication bypass in Alpine

> Attackers can bypass authentication filters in the Alpine Java library by manipulating request URIs, potentially accessing protected endpoints without valid credentials.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Dec 2022
- **Updated:** 10 Apr 2025
- **Also known as:** GHSA-whr2-9x5f-5c79

## What is CVE-2022-23554?

CVE-2022-23554 is a medium-severity authentication bypass vulnerability in stevespringett alpine, published on 28 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Alpine is a scaffolding library in Java. Alpine prior to version 1.10.4 allows Authentication Filter bypass. The AuthenticationFilter relies on the request URI to evaluate if the user is accessing the swagger endpoint. By accessing a URL with a path such as /api/foo;%2fapi%2fswagger the contains condition will hold and will return from the authentication filter without aborting the request. Note that the principal object will not be assigned and therefore the issue wont allow user impersonation. This issue has been fixed in version 1.10.4. There are no known workarounds.

Weakness: CWE-697 (Incorrect Comparison), CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2022-23554?

2 open source packages ship an affected version, including us.springett:alpine. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `us.springett:alpine` | Maven | All versions | 1.10.4 |
| `us.springett:alpine` | Maven | All versions | 1.10.4 |

Products: Alpine Project Alpine.

## How do I fix CVE-2022-23554?

Upgrade us.springett:alpine to 1.10.4 or later.

## Is CVE-2022-23554 being exploited?

There is no known exploitation of CVE-2022-23554 in the wild and no public exploit code.

## Other vulnerabilities in stevespringett alpine

- [CVE-2022-23553](https://insights.sbomify.com/CVE-2022-23553/): URL access filters bypass in Alpine (high 7.5)
- [CVE-2020-14929](https://insights.sbomify.com/CVE-2020-14929/): Security feature bypass in n/a (high 7.5)
- [CVE-2021-46853](https://insights.sbomify.com/CVE-2021-46853/): Race condition in n/a (medium 5.9)
- [CVE-2021-38370](https://insights.sbomify.com/CVE-2021-38370/): Security feature bypass in n/a (medium 5.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-23554 and fix it if it is affected.

What it is: CVE-2022-23554 is a medium-severity authentication bypass vulnerability in stevespringett alpine, published on 28 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-23554 in the wild and no public exploit code.

Affected packages and fixed versions:
- us.springett:alpine (Maven): affected all versions; fixed in 1.10.4
- us.springett:alpine (Maven): affected all versions; fixed in 1.10.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-23554/ (Markdown: https://insights.sbomify.com/CVE-2022-23554/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-23554
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-23554
- OSV: https://osv.dev/vulnerability/CVE-2022-23554

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-23554/
Summaries are generated and may contain mistakes; the official description above is the record.
