CVE-2022-23555 authentik vulnerable to Improper Authentication via invitation URL token reuse

Critical 9.4 Published Updated

Attackers can bypass authentication and gain unauthorized access by reusing invitation tokens across different enrollment flows in authentik.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2022-23555?

CVE-2022-23555 is a critical authentication bypass vulnerability in goauthentik authentik, published on 28 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

authentik is an open-source Identity Provider focused on flexibility and versatility. Versions prior to 2022.11.4 and 2022.10.4 are vulnerable to Improper Authentication. Token reuse in invitation URLs leads to access control bypass via the use of a different enrollment flow than in the one provided. The vulnerability allows an attacker that knows different invitation flows names (e.g. `enrollment-invitation-test` and `enrollment-invitation-admin`) via either different invite links or via brute forcing to signup via a single invitation url for any valid invite link received (it can even be a url for a third flow as long as it's a valid invite) as the token used in the `Invitations` section of the Admin interface does NOT change when a different `enrollment flow` is selected via the interface and it is NOT bound to the selected flow, so it will be valid for any flow when used. This issue is patched in authentik 2022.11.4,2022.10.4 and 2022.12.0. Only configurations that use invitations and have multiple enrollment flows with invitation stages that grant different permissions are affected. The default configuration is not vulnerable, and neither are configurations with a single enrollment flow. As a workaround, fixed data can be added to invitations which can be checked in the flow to deny requests. Alternatively, an identifier with high entropy (like a UUID) can be used as flow slug, mitigating the attack vector by exponentially decreasing the possibility of discovering other flows.

Weakness: CWE-287

Which versions are affected by CVE-2022-23555?

1 open source package ship an affected version, including authentik. It affects 1 product.

PackageAffectedFixed in
authentik BitnamiAll versions2022.10.4, 2022.11.4

Products include Goauthentik Authentik.

How do I fix CVE-2022-23555?

Upgrade authentik to a fixed version for your release line: 2022.10.4 or 2022.11.4.

Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.

Is CVE-2022-23555 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-23555 exists.

Sources

Also known as BIT-authentik-2022-23555, GHSA-9qwp-jf7p-vr7h.

Is CVE-2022-23555 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free