# CVE-2022-23555: authentik vulnerable to Improper Authentication via invitation URL token reuse

> Attackers can bypass authentication and gain unauthorized access by reusing invitation tokens across different enrollment flows in authentik.

- **Severity:** Critical 9.4 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Dec 2022
- **Updated:** 11 Apr 2025
- **Also known as:** BIT-authentik-2022-23555, GHSA-9qwp-jf7p-vr7h

## What is CVE-2022-23555?

CVE-2022-23555 is a critical authentication bypass vulnerability in goauthentik authentik, published on 28 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

authentik is an open-source Identity Provider focused on flexibility and versatility. Versions prior to 2022.11.4 and 2022.10.4 are vulnerable to Improper Authentication. Token reuse in invitation URLs leads to access control bypass via the use of a different enrollment flow than in the one provided. The vulnerability allows an attacker that knows different invitation flows names (e.g. `enrollment-invitation-test` and `enrollment-invitation-admin`) via either different invite links or via brute forcing to signup via a single invitation url for any valid invite link received (it can even be a url for a third flow as long as it's a valid invite) as the token used in the `Invitations` section of the Admin interface does NOT change when a different `enrollment flow` is selected via the interface and it is NOT bound to the selected flow, so it will be valid for any flow when used. This issue is patched in authentik 2022.11.4,2022.10.4 and 2022.12.0. Only configurations that use invitations and have multiple enrollment flows with invitation stages that grant different permissions are affected. The default configuration is not vulnerable, and neither are configurations with a single enrollment flow.  As a workaround, fixed data can be added to invitations which can be checked in the flow to deny requests. Alternatively, an identifier with high entropy (like a UUID) can be used as flow slug, mitigating the attack vector by exponentially decreasing the possibility of discovering other flows.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2022-23555?

1 open source package ship an affected version, including authentik. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `authentik` | Bitnami | All versions | 2022.10.4, 2022.11.4 |

Products: Goauthentik Authentik.

## How do I fix CVE-2022-23555?

Upgrade authentik to a fixed version for your release line: 2022.10.4 or 2022.11.4.

## Is CVE-2022-23555 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-23555 exists.

## Other vulnerabilities in goauthentik authentik

- [CVE-2026-49448](https://insights.sbomify.com/CVE-2026-49448/): authentik: SourceStage bypass via empty POST (critical 9.8)
- [CVE-2023-46249](https://insights.sbomify.com/CVE-2023-46249/): authentik potential installation takeover when default admin user is deleted (critical 9.7)
- [CVE-2026-42849](https://insights.sbomify.com/CVE-2026-42849/): authentik: Reflected XSS in SFE AutosubmitStage allows IDP account takeover (critical 9.3)
- [CVE-2026-25227](https://insights.sbomify.com/CVE-2026-25227/): authentik affected by Remote Code Execution via Context Key Injection in PropertyMapping Test Endpoint (critical 9.1)
- [CVE-2024-47070](https://insights.sbomify.com/CVE-2024-47070/): authentik vulnerable to password authentication bypass via X-Forwarded-For HTTP header (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-23555 and fix it if it is affected.

What it is: CVE-2022-23555 is a critical authentication bypass vulnerability in goauthentik authentik, published on 28 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-23555 exists.

Affected packages and fixed versions:
- authentik (Bitnami): affected all versions; fixed in 2022.10.4, 2022.11.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-23555/ (Markdown: https://insights.sbomify.com/CVE-2022-23555/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-23555
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-23555
- OSV: https://osv.dev/vulnerability/CVE-2022-23555

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-23555/
Summaries are generated and may contain mistakes; the official description above is the record.
