CVE-2022-23556 CodeIgniter is vulnerable to IP address spoofing when using proxy

High 7.0 Published Updated

Attackers can spoof IP addresses in CodeIgniter applications behind reverse proxies, bypassing IP-based security controls.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2022-23556?

CVE-2022-23556 is a high-severity vulnerability in CodeIgniter4, published on 22 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

CodeIgniter is a PHP full-stack web framework. This vulnerability may allow attackers to spoof their IP address when the server is behind a reverse proxy. This issue has been patched, please upgrade to version 4.2.11 or later, and configure `Config\App::$proxyIPs`. As a workaround, do not use `$request->getIPAddress()`.

Weakness: CWE-345

Which versions are affected by CVE-2022-23556?

3 open source packages ship an affected version, including codeigniter4/framework and codeigniter. It affects 1 product.

PackageAffectedFixed in
codeigniter4/framework PackagistAll versions4.2.11
codeigniter4/framework PackagistAll versions4.2.11
codeigniter BitnamiFrom 4.0.04.2.11

Products include Codeigniter Codeigniter.

How do I fix CVE-2022-23556?

Upgrade codeigniter4/framework to 4.2.11 or later.

Is CVE-2022-23556 being exploited?

There is no known exploitation of CVE-2022-23556 in the wild and no public exploit code.

Sources

Also known as BIT-codeigniter-2022-23556, GHSA-ghw3-5qvm-3mqc.

Is CVE-2022-23556 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free