{"answers":{"affected":"3 open source packages ship an affected version, including codeigniter4/framework and codeigniter. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-23556 in the wild and no public exploit code.","fix":"Upgrade codeigniter4/framework to 4.2.11 or later.","what":"CVE-2022-23556 is a high-severity vulnerability in CodeIgniter4, published on 22 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-23556 and fix it if it is affected.\n\nWhat it is: CVE-2022-23556 is a high-severity vulnerability in CodeIgniter4, published on 22 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-23556 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- codeigniter4/framework (Packagist): affected all versions; fixed in 4.2.11\n- codeigniter4/framework (Packagist): affected all versions; fixed in 4.2.11\n- codeigniter (Bitnami): affected from 4.0.0; fixed in 4.2.11\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-23556/ (Markdown: https://insights.sbomify.com/CVE-2022-23556/index.md)","id":"CVE-2022-23556","markdown":"https://insights.sbomify.com/CVE-2022-23556/index.md","name":"CVE-2022-23556","record":{"aliases":["BIT-codeigniter-2022-23556","GHSA-ghw3-5qvm-3mqc"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"PHP web framework","requires_auth":"none","summary":"Attackers can spoof IP addresses in CodeIgniter applications behind reverse proxies, bypassing IP-based security controls.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"codeigniter","vendor":"codeigniter"}],"cvss":{"score":7,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-345","name":"Insufficient Verification of Data Authenticity"}],"description":"CodeIgniter is a PHP full-stack web framework. This vulnerability may allow attackers to spoof their IP address when the server is behind a reverse proxy. This issue has been patched, please upgrade to version 4.2.11 or later, and configure `Config\\App::$proxyIPs`. As a workaround, do not use `$request-\u003egetIPAddress()`.","ecosystems":["Bitnami","Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"CodeIgniter is vulnerable to IP address spoofing when using proxy","id":"CVE-2022-23556","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"security_feature_bypass","year":"2022"},"n_packages":3,"n_references":2,"next":{"headline":"Division by zero in TFLite","id":"CVE-2022-23557"},"packages":[{"ecosystem":"Bitnami","fixed":["4.2.11"],"introduced":["4.0.0"],"last_affected":[],"package":"codeigniter","purl":"pkg:bitnami/codeigniter","source":"BIT-codeigniter-2022-23556"},{"ecosystem":"Packagist","fixed":["4.2.11"],"introduced":["0"],"last_affected":[],"package":"codeigniter4/framework","purl":null,"source":"GHSA-ghw3-5qvm-3mqc"},{"ecosystem":"Packagist","fixed":["4.2.11"],"introduced":["0"],"last_affected":[],"package":"codeigniter4/framework","purl":"pkg:composer/codeigniter4/framework","source":"GHSA-ghw3-5qvm-3mqc"}],"prev":{"headline":"authentik vulnerable to Improper Authentication via invitation URL token reuse","id":"CVE-2022-23555"},"products":["CodeIgniter4"],"published":"2022-12-22","related":[{"cvss_score":9.8,"headline":"CodeIgniter4's ImageMagick Handler has Command Injection Vulnerability","id":"CVE-2025-54418","kev_date_added":null,"published":"2025-07-28"},{"cvss_score":9.8,"headline":"Remote Code Execution Vulnerability in Validation Placeholders","id":"CVE-2023-32692","kev_date_added":null,"published":"2023-05-30"},{"cvss_score":9.8,"headline":"SQL injection in n/a","id":"CVE-2022-40824","kev_date_added":null,"published":"2022-10-07"},{"cvss_score":9.8,"headline":"SQL injection in n/a","id":"CVE-2022-40825","kev_date_added":null,"published":"2022-10-07"},{"cvss_score":9.8,"headline":"SQL injection in n/a","id":"CVE-2022-40826","kev_date_added":null,"published":"2022-10-07"},{"cvss_score":9.8,"headline":"SQL injection in n/a","id":"CVE-2022-40827","kev_date_added":null,"published":"2022-10-07"},{"cvss_score":9.8,"headline":"SQL injection in n/a","id":"CVE-2022-40828","kev_date_added":null,"published":"2022-10-07"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-15","vendors":["codeigniter4"]},"summary":"Attackers can spoof IP addresses in CodeIgniter applications behind reverse proxies, bypassing IP-based security controls.","url":"https://insights.sbomify.com/CVE-2022-23556/"}