CVE-2022-23590 Crash due to erroneous `StatusOr` in Tensorflow

Medium 5.9 Published Updated

Attackers can crash TensorFlow processes by providing a maliciously altered SavedModel, requiring an upgrade to patched versions.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2022-23590?

CVE-2022-23590 is a medium-severity denial of service vulnerability in Google Tensorflow, published on 4 Feb 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Tensorflow is an Open Source Machine Learning Framework. A `GraphDef` from a TensorFlow `SavedModel` can be maliciously altered to cause a TensorFlow process to crash due to encountering a `StatusOr` value that is an error and forcibly extracting the value from it. We have patched the issue in multiple GitHub commits and these will be included in TensorFlow 2.8.0 and TensorFlow 2.7.1, as both are affected.

Weakness: CWE-754

Which versions are affected by CVE-2022-23590?

10 open source packages ship an affected version, including tensorflow, tensorflow-cpu and tensorflow-gpu. It affects 1 product.

PackageAffectedFixed in
tensorflow BitnamiAll versions2.7.1
tensorflow PyPIAll versions2.7.1
tensorflow PyPIAll versions2.7.1
tensorflow PyPIAll versions2.7.1
tensorflow-cpu PyPIAll versions2.7.1
tensorflow-cpu PyPIAll versions2.7.1
4 more packages
tensorflow-cpu PyPIAll versions2.7.1
tensorflow-gpu PyPIAll versions2.7.1
tensorflow-gpu PyPIAll versions2.7.1
tensorflow-gpu PyPIAll versions2.7.1

Products include Google Tensorflow.

How do I fix CVE-2022-23590?

Upgrade tensorflow to 2.7.1 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2022-23590 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-23590 exists.

All Google Tensorflow vulnerabilities

Sources

Also known as BIT-tensorflow-2022-23590, GHSA-pqrv-8r2f-7278, PYSEC-2022-154, PYSEC-2022-99, PYSEC-2026-3225.

Is CVE-2022-23590 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free