# CVE-2022-23590: Crash due to erroneous `StatusOr` in Tensorflow

> Attackers can crash TensorFlow processes by providing a maliciously altered SavedModel, requiring an upgrade to patched versions.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Feb 2022
- **Updated:** 22 Apr 2025
- **Also known as:** BIT-tensorflow-2022-23590, GHSA-pqrv-8r2f-7278, PYSEC-2022-154, PYSEC-2022-99, PYSEC-2026-3225

## What is CVE-2022-23590?

CVE-2022-23590 is a medium-severity denial of service vulnerability in Google Tensorflow, published on 4 Feb 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Tensorflow is an Open Source Machine Learning Framework. A `GraphDef` from a TensorFlow `SavedModel` can be maliciously altered to cause a TensorFlow process to crash due to encountering a `StatusOr` value that is an error and forcibly extracting the value from it. We have patched the issue in multiple GitHub commits and these will be included in TensorFlow 2.8.0 and TensorFlow 2.7.1, as both are affected.

Weakness: CWE-754 (Improper Check for Unusual or Exceptional Conditions)

## Which versions are affected by CVE-2022-23590?

10 open source packages ship an affected version, including tensorflow, tensorflow-cpu and tensorflow-gpu. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `tensorflow` | Bitnami | All versions | 2.7.1 |
| `tensorflow` | PyPI | All versions | 2.7.1 |
| `tensorflow` | PyPI | All versions | 2.7.1 |
| `tensorflow` | PyPI | All versions | 2.7.1 |
| `tensorflow-cpu` | PyPI | All versions | 2.7.1 |
| `tensorflow-cpu` | PyPI | All versions | 2.7.1 |
| `tensorflow-cpu` | PyPI | All versions | 2.7.1 |
| `tensorflow-gpu` | PyPI | All versions | 2.7.1 |
| `tensorflow-gpu` | PyPI | All versions | 2.7.1 |
| `tensorflow-gpu` | PyPI | All versions | 2.7.1 |

Products: Google Tensorflow.

## How do I fix CVE-2022-23590?

Upgrade tensorflow to 2.7.1 or later.

## Is CVE-2022-23590 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-23590 exists.

## Other vulnerabilities in Google Tensorflow

- [CVE-2023-25668](https://insights.sbomify.com/CVE-2023-25668/): TensorFlow vulnerable to heap out-of-buffer read in the QuantizeAndDequantize operation (critical 9.8)
- [CVE-2018-7575](https://insights.sbomify.com/CVE-2018-7575/): Integer Overflow or Wraparound in Google TensorFlow (critical 9.8)
- [CVE-2021-37678](https://insights.sbomify.com/CVE-2021-37678/): Arbitrary code execution due to YAML deserialization (critical 9.3)
- [CVE-2021-35958](https://insights.sbomify.com/CVE-2021-35958/): Path traversal in n/a (critical 9.1)
- [CVE-2020-15202](https://insights.sbomify.com/CVE-2020-15202/): Integer truncation in Shard API usage (critical 9.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-23590 and fix it if it is affected.

What it is: CVE-2022-23590 is a medium-severity denial of service vulnerability in Google Tensorflow, published on 4 Feb 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-23590 exists.

Affected packages and fixed versions:
- tensorflow (Bitnami): affected all versions; fixed in 2.7.1
- tensorflow (PyPI): affected all versions; fixed in 2.7.1
- tensorflow (PyPI): affected all versions; fixed in 2.7.1
- tensorflow (PyPI): affected all versions; fixed in 2.7.1
- tensorflow-cpu (PyPI): affected all versions; fixed in 2.7.1
- tensorflow-cpu (PyPI): affected all versions; fixed in 2.7.1
- tensorflow-cpu (PyPI): affected all versions; fixed in 2.7.1
- tensorflow-gpu (PyPI): affected all versions; fixed in 2.7.1
- tensorflow-gpu (PyPI): affected all versions; fixed in 2.7.1
- tensorflow-gpu (PyPI): affected all versions; fixed in 2.7.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-23590/ (Markdown: https://insights.sbomify.com/CVE-2022-23590/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-23590
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-23590
- OSV: https://osv.dev/vulnerability/CVE-2022-23590

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-23590/
Summaries are generated and may contain mistakes; the official description above is the record.
