# CVE-2022-23592: Out of bounds read in Tensorflow

> An attacker can trigger a heap out-of-bounds read in TensorFlow's type inference, potentially leading to information disclosure or crashes.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Feb 2022
- **Updated:** 22 Apr 2025
- **Also known as:** BIT-tensorflow-2022-23592, GHSA-vq36-27g6-p492, PYSEC-2022-101, PYSEC-2022-156, PYSEC-2026-3249

## What is CVE-2022-23592?

CVE-2022-23592 is a high-severity memory corruption vulnerability in Google Tensorflow, published on 4 Feb 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Tensorflow is an Open Source Machine Learning Framework. TensorFlow's type inference can cause a heap out of bounds read as the bounds checking is done in a `DCHECK` (which is a no-op during production). An attacker can control the `input_idx` variable such that `ix` would be larger than the number of values in `node_t.args`. The fix will be included in TensorFlow 2.8.0. This is the only affected version.

Weakness: CWE-125 (Out-of-bounds Read)

## Which versions are affected by CVE-2022-23592?

10 open source packages ship an affected version, including tensorflow, tensorflow-cpu and tensorflow-gpu. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `tensorflow` | Bitnami | From 2.7.0 | 2.8.0 |
| `tensorflow` | PyPI | From 2.8.0-rc0 | 2.8.0 |
| `tensorflow` | PyPI | From 2.8.0-rc0 | 2.8.0 |
| `tensorflow` | PyPI | From 2.8.0-rc0 | 2.8.0 |
| `tensorflow-cpu` | PyPI | From 2.7.0 | 2.8.0 |
| `tensorflow-cpu` | PyPI | From 2.8.0-rc0 | 2.8.0 |
| `tensorflow-cpu` | PyPI | From 2.8.0-rc0 | 2.8.0 |
| `tensorflow-gpu` | PyPI | From 2.7.0 | 2.8.0 |
| `tensorflow-gpu` | PyPI | From 2.8.0-rc0 | 2.8.0 |
| `tensorflow-gpu` | PyPI | From 2.8.0-rc0 | 2.8.0 |

Products: Google Tensorflow.

## How do I fix CVE-2022-23592?

Upgrade tensorflow to 2.8.0 or later.

## Is CVE-2022-23592 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-23592 exists.

## Other vulnerabilities in Google Tensorflow

- [CVE-2023-25668](https://insights.sbomify.com/CVE-2023-25668/): TensorFlow vulnerable to heap out-of-buffer read in the QuantizeAndDequantize operation (critical 9.8)
- [CVE-2018-7575](https://insights.sbomify.com/CVE-2018-7575/): Integer Overflow or Wraparound in Google TensorFlow (critical 9.8)
- [CVE-2021-37678](https://insights.sbomify.com/CVE-2021-37678/): Arbitrary code execution due to YAML deserialization (critical 9.3)
- [CVE-2021-35958](https://insights.sbomify.com/CVE-2021-35958/): Path traversal in n/a (critical 9.1)
- [CVE-2020-15202](https://insights.sbomify.com/CVE-2020-15202/): Integer truncation in Shard API usage (critical 9.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-23592 and fix it if it is affected.

What it is: CVE-2022-23592 is a high-severity memory corruption vulnerability in Google Tensorflow, published on 4 Feb 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-23592 exists.

Affected packages and fixed versions:
- tensorflow (Bitnami): affected from 2.7.0; fixed in 2.8.0
- tensorflow (PyPI): affected from 2.8.0-rc0; fixed in 2.8.0
- tensorflow (PyPI): affected from 2.8.0-rc0; fixed in 2.8.0
- tensorflow (PyPI): affected from 2.8.0-rc0; fixed in 2.8.0
- tensorflow-cpu (PyPI): affected from 2.7.0; fixed in 2.8.0
- tensorflow-cpu (PyPI): affected from 2.8.0-rc0; fixed in 2.8.0
- tensorflow-cpu (PyPI): affected from 2.8.0-rc0; fixed in 2.8.0
- tensorflow-gpu (PyPI): affected from 2.7.0; fixed in 2.8.0
- tensorflow-gpu (PyPI): affected from 2.8.0-rc0; fixed in 2.8.0
- tensorflow-gpu (PyPI): affected from 2.8.0-rc0; fixed in 2.8.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-23592/ (Markdown: https://insights.sbomify.com/CVE-2022-23592/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-23592
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-23592
- OSV: https://osv.dev/vulnerability/CVE-2022-23592

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-23592/
Summaries are generated and may contain mistakes; the official description above is the record.
