CVE-2022-23593 Segfault in `simplifyBroadcast` in Tensorflow

Medium 5.9 Published Updated

An attacker can cause a denial of service via a segmentation fault in the simplifyBroadcast function when processing scalar shapes.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2022-23593?

CVE-2022-23593 is a medium-severity denial of service vulnerability in Google Tensorflow, published on 4 Feb 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Tensorflow is an Open Source Machine Learning Framework. The `simplifyBroadcast` function in the MLIR-TFRT infrastructure in TensorFlow is vulnerable to a segfault (hence, denial of service), if called with scalar shapes. If all shapes are scalar, then `maxRank` is 0, so we build an empty `SmallVector`. The fix will be included in TensorFlow 2.8.0. This is the only affected version.

Weakness: CWE-754

Which versions are affected by CVE-2022-23593?

10 open source packages ship an affected version, including tensorflow, tensorflow-cpu and tensorflow-gpu. It affects 1 product.

PackageAffectedFixed in
tensorflow BitnamiFrom 2.7.02.8.0
tensorflow PyPIFrom 2.8.0-rc02.8.0
tensorflow PyPIFrom 2.8.0-rc02.8.0
tensorflow PyPIFrom 2.8.0-rc02.8.0
tensorflow-cpu PyPIFrom 2.7.02.8.0
tensorflow-cpu PyPIFrom 2.8.0-rc02.8.0
4 more packages
tensorflow-cpu PyPIFrom 2.8.0-rc02.8.0
tensorflow-gpu PyPIFrom 2.7.02.8.0
tensorflow-gpu PyPIFrom 2.8.0-rc02.8.0
tensorflow-gpu PyPIFrom 2.8.0-rc02.8.0

Products include Google Tensorflow.

How do I fix CVE-2022-23593?

Upgrade tensorflow to 2.8.0 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2022-23593 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-23593 exists.

All Google Tensorflow vulnerabilities

Sources

Also known as BIT-tensorflow-2022-23593, GHSA-gwcx-jrx4-92w2, PYSEC-2022-102, PYSEC-2022-157, PYSEC-2026-3193.

Is CVE-2022-23593 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free