# CVE-2022-23594: Out of bounds read in Tensorflow

> Attackers can trigger out-of-bounds reads or writes in TensorFlow by providing a malicious SavedModel, potentially leading to code execution or crashes.

- **Severity:** High 8.8 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Feb 2022
- **Updated:** 23 Apr 2025
- **Also known as:** BIT-tensorflow-2022-23594, GHSA-9x52-887g-fhc2, PYSEC-2026-3157, PYSEC-2026-3309, PYSEC-2026-752

## What is CVE-2022-23594?

CVE-2022-23594 is a high-severity memory corruption vulnerability in Google Tensorflow, published on 4 Feb 2022. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Tensorflow is an Open Source Machine Learning Framework. The TFG dialect of TensorFlow (MLIR) makes several assumptions about the incoming `GraphDef` before converting it to the MLIR-based dialect. If an attacker changes the `SavedModel` format on disk to invalidate these assumptions and the `GraphDef` is then converted to MLIR-based IR then they can cause a crash in the Python interpreter. Under certain scenarios, heap OOB read/writes are possible. These issues have been discovered via fuzzing and it is possible that more weaknesses exist. We will patch them as they are discovered.

Weakness: CWE-787 (Out-of-bounds Write), CWE-125 (Out-of-bounds Read)

## Which versions are affected by CVE-2022-23594?

10 open source packages ship an affected version, including tensorflow, tensorflow-cpu and tensorflow-gpu. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `tensorflow` | Bitnami | From 2.7.0 | 2.7.1 |
| `tensorflow` | PyPI | From 2.7.0 | 2.7.1 |
| `tensorflow` | PyPI | From 2.7.0 | 2.7.1 |
| `tensorflow` | PyPI | From 2.7.0 | 2.7.1 |
| `tensorflow-cpu` | PyPI | From 2.7.0 | 2.7.1 |
| `tensorflow-cpu` | PyPI | From 2.7.0 | 2.7.1 |
| `tensorflow-cpu` | PyPI | From 2.7.0 | 2.7.1 |
| `tensorflow-gpu` | PyPI | From 2.7.0 | 2.7.1 |
| `tensorflow-gpu` | PyPI | From 2.7.0 | 2.7.1 |
| `tensorflow-gpu` | PyPI | From 2.7.0 | 2.7.1 |

Products: Google Tensorflow.

## How do I fix CVE-2022-23594?

Upgrade tensorflow to 2.7.1 or later.

## Is CVE-2022-23594 being exploited?

There is no known exploitation of CVE-2022-23594 in the wild and no public exploit code.

## Other vulnerabilities in Google Tensorflow

- [CVE-2023-25668](https://insights.sbomify.com/CVE-2023-25668/): TensorFlow vulnerable to heap out-of-buffer read in the QuantizeAndDequantize operation (critical 9.8)
- [CVE-2018-7575](https://insights.sbomify.com/CVE-2018-7575/): Integer Overflow or Wraparound in Google TensorFlow (critical 9.8)
- [CVE-2021-37678](https://insights.sbomify.com/CVE-2021-37678/): Arbitrary code execution due to YAML deserialization (critical 9.3)
- [CVE-2021-35958](https://insights.sbomify.com/CVE-2021-35958/): Path traversal in n/a (critical 9.1)
- [CVE-2020-15202](https://insights.sbomify.com/CVE-2020-15202/): Integer truncation in Shard API usage (critical 9.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-23594 and fix it if it is affected.

What it is: CVE-2022-23594 is a high-severity memory corruption vulnerability in Google Tensorflow, published on 4 Feb 2022. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-23594 in the wild and no public exploit code.

Affected packages and fixed versions:
- tensorflow (Bitnami): affected from 2.7.0; fixed in 2.7.1
- tensorflow (PyPI): affected from 2.7.0; fixed in 2.7.1
- tensorflow (PyPI): affected from 2.7.0; fixed in 2.7.1
- tensorflow (PyPI): affected from 2.7.0; fixed in 2.7.1
- tensorflow-cpu (PyPI): affected from 2.7.0; fixed in 2.7.1
- tensorflow-cpu (PyPI): affected from 2.7.0; fixed in 2.7.1
- tensorflow-cpu (PyPI): affected from 2.7.0; fixed in 2.7.1
- tensorflow-gpu (PyPI): affected from 2.7.0; fixed in 2.7.1
- tensorflow-gpu (PyPI): affected from 2.7.0; fixed in 2.7.1
- tensorflow-gpu (PyPI): affected from 2.7.0; fixed in 2.7.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-23594/ (Markdown: https://insights.sbomify.com/CVE-2022-23594/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-23594
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-23594
- OSV: https://osv.dev/vulnerability/CVE-2022-23594

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-23594/
Summaries are generated and may contain mistakes; the official description above is the record.
