# CVE-2022-23598: Reflected XSS vulnerability when rendering error messages in laminas-form

> Attackers can execute arbitrary scripts in victim browsers via reflected XSS in laminas-form error message rendering.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 28 Jan 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-jq4p-mq33-w375

## What is CVE-2022-23598?

CVE-2022-23598 is a medium-severity cross-site scripting vulnerability in Fedoraproject Fedora, published on 28 Jan 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

laminas-form is a package for validating and displaying simple and complex forms. When rendering validation error messages via the `formElementErrors()` view helper shipped with laminas-form, many messages will contain the submitted value. However, in laminas-form prior to version 3.1.1, the value was not being escaped for HTML contexts, which could potentially lead to a reflected cross-site scripting attack. Versions 3.1.1 and above contain a patch to mitigate the vulnerability. A workaround is available. One may manually place code at the top of a view script where one calls the `formElementErrors()` view helper. More information about this workaround is available on the GitHub Security Advisory.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2022-23598?

6 open source packages ship an affected version, including laminas/laminas-form. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `laminas/laminas-form` | Packagist | All versions | 2.17.1 |
| `laminas/laminas-form` | Packagist | All versions | 2.17.1 |
| `laminas/laminas-form` | Packagist | From 3.0.0 | 3.0.2 |
| `laminas/laminas-form` | Packagist | From 3.0.0 | 3.0.2 |
| `laminas/laminas-form` | Packagist | From 3.1.0 | 3.1.1 |
| `laminas/laminas-form` | Packagist | From 3.1.0 | 3.1.1 |

Products: Fedoraproject Fedora, Getlaminas Laminas-Form.

## How do I fix CVE-2022-23598?

Upgrade laminas/laminas-form to a fixed version for your release line: 2.17.1, 3.0.2 or 3.1.1.

## Is CVE-2022-23598 being exploited?

There is no known exploitation of CVE-2022-23598 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-23598 and fix it if it is affected.

What it is: CVE-2022-23598 is a medium-severity cross-site scripting vulnerability in Fedoraproject Fedora, published on 28 Jan 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-23598 in the wild and no public exploit code.

Affected packages and fixed versions:
- laminas/laminas-form (Packagist): affected all versions; fixed in 2.17.1
- laminas/laminas-form (Packagist): affected all versions; fixed in 2.17.1
- laminas/laminas-form (Packagist): affected from 3.0.0; fixed in 3.0.2
- laminas/laminas-form (Packagist): affected from 3.0.0; fixed in 3.0.2
- laminas/laminas-form (Packagist): affected from 3.1.0; fixed in 3.1.1
- laminas/laminas-form (Packagist): affected from 3.1.0; fixed in 3.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-23598/ (Markdown: https://insights.sbomify.com/CVE-2022-23598/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-23598
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-23598
- OSV: https://osv.dev/vulnerability/CVE-2022-23598

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-23598/
Summaries are generated and may contain mistakes; the official description above is the record.
