# CVE-2022-23599: Cross-site Scripting and Open Redirect in Products.ATContentTypes

> Attackers can inject scripts or redirect users via cache poisoning in Plone's image view, affecting visitors with cached pages.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 28 Jan 2022
- **Updated:** 5 May 2025
- **Also known as:** GHSA-g4c2-ghfg-g5rh, PYSEC-2022-21

## What is CVE-2022-23599?

CVE-2022-23599 is a medium-severity cross-site scripting vulnerability in Plone Plone, published on 28 Jan 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Products.ATContentTypes are the core content types for Plone 2.1 - 4.3. Versions of Plone that are dependent on Products.ATContentTypes prior to version 3.0.6 are vulnerable to reflected cross site scripting and open redirect when an attacker can get a compromised version of the image_view_fullscreen page in a cache, for example in Varnish. The technique is known as cache poisoning. Any later visitor can get redirected when clicking on a link on this page. Usually only anonymous users are affected, but this depends on the user's cache settings. Version 3.0.6 of Products.ATContentTypes has been released with a fix. This version works on Plone 5.2, Python 2 only. As a workaround, make sure the image_view_fullscreen page is not stored in the cache. More information about the vulnerability and cvmitigation measures is available in the GitHub Security Advisory.

Weakness: CWE-601 (URL Redirection to Untrusted Site), CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2022-23599?

3 open source packages ship an affected version, including products-atcontenttypes and Products.ATContentTypes. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `products-atcontenttypes` | PyPI | All versions | 3.0.6 |
| `products-atcontenttypes` | PyPI | All versions | 3.0.6 |
| `Products.ATContentTypes` | PyPI | All versions | 3.0.6 |

Products: Plone Plone.

## How do I fix CVE-2022-23599?

Upgrade products-atcontenttypes to 3.0.6 or later.

## Is CVE-2022-23599 being exploited?

There is no known exploitation of CVE-2022-23599 in the wild and no public exploit code.

## Other vulnerabilities in Plone Plone

- [CVE-2021-33509](https://insights.sbomify.com/CVE-2021-33509/): Incorrect Permission Assignment for Critical Resource in Plone (critical 9.9)
- [CVE-2020-35190](https://insights.sbomify.com/CVE-2020-35190/): Hardcoded credentials in n/a (critical 9.8)
- [CVE-2020-7941](https://insights.sbomify.com/CVE-2020-7941/): Plone Unauthenticated Write Vulnerability (critical 9.8)
- [CVE-2011-3587](https://insights.sbomify.com/CVE-2011-3587/): Zope Command Execution Vulnerability (critical 9.3)
- [CVE-2021-33926](https://insights.sbomify.com/CVE-2021-33926/): Server-Side Request Forgery in Plone CMS (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-23599 and fix it if it is affected.

What it is: CVE-2022-23599 is a medium-severity cross-site scripting vulnerability in Plone Plone, published on 28 Jan 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-23599 in the wild and no public exploit code.

Affected packages and fixed versions:
- products-atcontenttypes (PyPI): affected all versions; fixed in 3.0.6
- products-atcontenttypes (PyPI): affected all versions; fixed in 3.0.6
- Products.ATContentTypes (PyPI): affected all versions; fixed in 3.0.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-23599/ (Markdown: https://insights.sbomify.com/CVE-2022-23599/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-23599
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-23599
- OSV: https://osv.dev/vulnerability/CVE-2022-23599

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-23599/
Summaries are generated and may contain mistakes; the official description above is the record.
