# CVE-2022-23600: Limited ability to spoof SAML authentication with missing audience verification

> Attackers can spoof SAML authentication to access Fleet accounts if audience verification is missing, affecting deployments using SAML SSO.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Feb 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-ch68-7cf4-35vr

## What is CVE-2022-23600?

CVE-2022-23600 is a medium-severity authentication bypass vulnerability in fleetdm fleet, published on 4 Feb 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

fleet is an open source device management, built on osquery. Versions prior to 4.9.1 expose a limited ability to spoof SAML authentication with missing audience verification. This impacts deployments using SAML SSO in two specific cases: 1. A malicious or compromised Service Provider (SP) could reuse the SAML response to log into Fleet as a user -- only if the user has an account with the same email in Fleet, _and_ the user signs into the malicious SP via SAML SSO from the same Identity Provider (IdP) configured with Fleet. 2. A user with an account in Fleet could reuse a SAML response intended for another SP to log into Fleet. This is only a concern if the user is blocked from Fleet in the IdP, but continues to have an account in Fleet. If the user is blocked from the IdP entirely, this cannot be exploited. Fleet 4.9.1 resolves this issue. Users unable to upgrade should: Reduce the length of sessions on your IdP to reduce the window for malicious re-use, Limit the amount of SAML Service Providers/Applications used by user accounts with access to Fleet, and When removing access to Fleet in the IdP, delete the Fleet user from Fleet as well.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2022-23600?

2 open source packages ship an affected version, including github.com/fleetdm/fleet/v4. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/fleetdm/fleet/v4` | Go | All versions | 4.9.1 |
| `github.com/fleetdm/fleet/v4` | Go | All versions | 4.9.1 |

Products: Fleetdm Fleet.

## How do I fix CVE-2022-23600?

Upgrade github.com/fleetdm/fleet/v4 to 4.9.1 or later.

## Is CVE-2022-23600 being exploited?

There is no known exploitation of CVE-2022-23600 in the wild and no public exploit code.

## Other vulnerabilities in fleetdm fleet

- [CVE-2020-26276](https://insights.sbomify.com/CVE-2020-26276/): SAML authentication vulnerability in Fleet (critical 10.0)
- [CVE-2026-103264](https://insights.sbomify.com/CVE-2026-103264/): Fleet before 4.87.0 Authentication Bypass via Device Identifiers (critical 9.3)
- [CVE-2026-23518](https://insights.sbomify.com/CVE-2026-23518/): Fleet has a JWT signature bypass vulnerability in Azure AD MDM enrollment (critical 9.3)
- [CVE-2026-26062](https://insights.sbomify.com/CVE-2026-26062/): Fleet server may terminate unexpectedly when handling certain gRPC requests (high 8.7)
- [CVE-2026-26061](https://insights.sbomify.com/CVE-2026-26061/): Fleet's unbounded request body read allows remote Denial of Service (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-23600 and fix it if it is affected.

What it is: CVE-2022-23600 is a medium-severity authentication bypass vulnerability in fleetdm fleet, published on 4 Feb 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-23600 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/fleetdm/fleet/v4 (Go): affected all versions; fixed in 4.9.1
- github.com/fleetdm/fleet/v4 (Go): affected all versions; fixed in 4.9.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-23600/ (Markdown: https://insights.sbomify.com/CVE-2022-23600/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-23600
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-23600
- OSV: https://osv.dev/vulnerability/CVE-2022-23600

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-23600/
Summaries are generated and may contain mistakes; the official description above is the record.
