{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-23604 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2022-23604 yet. Limit exposure of the affected software until one is available.","what":"CVE-2022-23604 is a high-severity vulnerability in Twentysix26 x26-Cogs, published on 15 Feb 2022. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-23604 and fix it if it is affected.\n\nWhat it is: CVE-2022-23604 is a high-severity vulnerability in Twentysix26 x26-Cogs, published on 15 Feb 2022. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-23604 in the wild and no public exploit code.\n\nAffected product: Twentysix26 x26-Cogs. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-23604/ (Markdown: https://insights.sbomify.com/CVE-2022-23604/index.md)","id":"CVE-2022-23604","markdown":"https://insights.sbomify.com/CVE-2022-23604/index.md","name":"CVE-2022-23604","record":{"aliases":["GHSA-cfh8-v56j-5757"],"analysis":{"component_type":"other","fix_type":"upgrade","impacts":["privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"Discord bot cog","requires_auth":"low_privilege","summary":"Server admins can execute bot-owner restricted commands by impersonating other users, requiring an upgrade to the Defender cog.","user_interaction":"not_required","vuln_class":"privilege_escalation"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"x26-cogs","vendor":"x26-cogs_project"}],"cvss":{"score":8.8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-269","name":"Improper Privilege Management"}],"description":"x26-Cogs is a repository of cogs made by Twentysix for the Red Discord bot. Among these cogs is the Defender cog, a tool for Discord server moderation. A vulnerability in the Defender cog prior to version 1.10.0 allows users with admin privileges to issue commands as other users who share the same server. If a bot owner shares the same server as the attacker, it is possible for the attacker to issue bot-owner restricted commands. The issue has been patched in version 1.10.0. One may unload the Defender cog as a workaround.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"Privilege escalation in Defender","id":"CVE-2022-23604","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"privilege_escalation","year":"2022"},"n_packages":0,"n_references":3,"next":{"headline":"Expired Ephemeral Messages not reliably removed in wire-webapp","id":"CVE-2022-23605"},"packages":[],"prev":{"headline":"Code injection in iTunesRPC-Remastered","id":"CVE-2022-23603"},"products":["x26-Cogs"],"published":"2022-02-15","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-04-23","vendors":["Twentysix26"]},"summary":"Server admins can execute bot-owner restricted commands by impersonating other users, requiring an upgrade to the Defender cog.","url":"https://insights.sbomify.com/CVE-2022-23604/"}