# CVE-2022-23607: Unsafe handling of user-specified cookies in treq

> Attackers can steal sensitive session cookies via cross-domain redirects because treq sends user-specified cookies to all domains.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 1 Feb 2022
- **Updated:** 3 Aug 2024
- **Also known as:** DEBIAN-CVE-2022-23607, DLA-2954-1, GHSA-fhpf-pp6p-55qc, PYSEC-2022-26, UBUNTU-CVE-2022-23607, openSUSE-SU-2022:10098-1, openSUSE-SU-2024:11806-1, openSUSE-SU-2025:15106-1

## What is CVE-2022-23607?

CVE-2022-23607 is a medium-severity vulnerability in Debian Debian Linux, published on 1 Feb 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

treq is an HTTP library inspired by requests but written on top of Twisted's Agents. Treq's request methods (`treq.get`, `treq.post`, etc.) and `treq.client.HTTPClient` constructor accept cookies as a dictionary. Such cookies are not bound to a single domain, and are therefore sent to *every* domain ("supercookies"). This can potentially cause sensitive information to leak upon an HTTP redirect to a different domain., e.g. should `https://example.com` redirect to `http://cloudstorageprovider.com` the latter will receive the cookie `session`. Treq 2021.1.0 and later bind cookies given to request methods (`treq.request`, `treq.get`, `HTTPClient.request`, `HTTPClient.get`, etc.) to the origin of the *url* parameter. Users are advised to upgrade. For users unable to upgrade Instead of passing a dictionary as the *cookies* argument, pass a `http.cookiejar.CookieJar` instance with properly domain- and scheme-scoped cookies in it.

Weakness: CWE-425 (Direct Request), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2022-23607?

3 open source packages ship an affected version, including treq. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `treq` | PyPI | All versions | 22.1.0 |
| `treq` | PyPI | All versions | 22.1.0 |
| `treq` | PyPI | From 21.1.0 | 22.1.0 |
| `python-treq` | SUSE:Package Hub 15 SP3 | All versions | 20.3.0-bp153.2.3.1 |
| `python-treq` | openSUSE:Leap 15.3 | All versions | 20.3.0-bp153.2.3.1 |
| `python-treq` | openSUSE:Tumbleweed | All versions | 22.1.0-1.1 |
| `python-treq` | openSUSE:Tumbleweed | All versions | 24.9.1-1.4 |

Products: Debian Debian Linux, Twistedmatrix Treq.

## How do I fix CVE-2022-23607?

Upgrade treq to 22.1.0 or later.

## Is CVE-2022-23607 being exploited?

There is no known exploitation of CVE-2022-23607 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-23607 and fix it if it is affected.

What it is: CVE-2022-23607 is a medium-severity vulnerability in Debian Debian Linux, published on 1 Feb 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-23607 in the wild and no public exploit code.

Affected packages and fixed versions:
- treq (PyPI): affected all versions; fixed in 22.1.0
- treq (PyPI): affected all versions; fixed in 22.1.0
- treq (PyPI): affected from 21.1.0; fixed in 22.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-23607/ (Markdown: https://insights.sbomify.com/CVE-2022-23607/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-23607
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-23607
- OSV: https://osv.dev/vulnerability/CVE-2022-23607

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-23607/
Summaries are generated and may contain mistakes; the official description above is the record.
