CVE-2022-23613 Privilege escalation on xrdp
An integer underflow in xrdp sesman allows local unauthenticated attackers to execute code as root via heap overflow.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Local or same network only
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-23613?
CVE-2022-23613 is a high-severity vulnerability in Fedoraproject Fedora, published on 7 Feb 2022. It can only be exploited from the same machine or local network, with no action from the victim.
Official description
xrdp is an open source remote desktop protocol (RDP) server. In affected versions an integer underflow leading to a heap overflow in the sesman server allows any unauthenticated attacker which is able to locally access a sesman server to execute code as root. This vulnerability has been patched in version 0.9.18.1 and above. Users are advised to upgrade. There are no known workarounds.
Weakness: CWE-191
Which versions are affected by CVE-2022-23613?
It affects 2 products.
Linux distribution packages (1)
xrdp openSUSE:Tumbleweed | All versions | 0.9.19-1.1 |
Products include Fedoraproject Fedora, Neutrinolabs Xrdp.
How do I fix CVE-2022-23613?
Upgrade to a fixed version.
Is CVE-2022-23613 being exploited?
There is no known exploitation of CVE-2022-23613 in the wild and no public exploit code.
Other vulnerabilities in Fedoraproject Fedora
Sources
Also known as DEBIAN-CVE-2022-23613, GHSA-8h98-h426-xf32, UBUNTU-CVE-2022-23613, openSUSE-SU-2024:12112-1.