{"answers":{"affected":"It affects 2 products.","exploited":"There is no known exploitation of CVE-2022-23613 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2022-23613 is a high-severity vulnerability in Fedoraproject Fedora, published on 7 Feb 2022. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-23613 and fix it if it is affected.\n\nWhat it is: CVE-2022-23613 is a high-severity vulnerability in Fedoraproject Fedora, published on 7 Feb 2022. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-23613 in the wild and no public exploit code.\n\nAffected product: Fedoraproject Fedora. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-23613/ (Markdown: https://insights.sbomify.com/CVE-2022-23613/index.md)","id":"CVE-2022-23613","markdown":"https://insights.sbomify.com/CVE-2022-23613/index.md","name":"CVE-2022-23613","record":{"aliases":["DEBIAN-CVE-2022-23613","GHSA-8h98-h426-xf32","UBUNTU-CVE-2022-23613","openSUSE-SU-2024:12112-1"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution","privilege_escalation"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"RDP server","requires_auth":"low_privilege","summary":"An integer underflow in xrdp sesman allows local unauthenticated attackers to execute code as root via heap overflow.","user_interaction":"not_required","vuln_class":"integer_overflow"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"fedora","vendor":"fedoraproject"},{"product":"xrdp","vendor":"neutrinolabs"}],"cvss":{"score":7.8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-191","name":"Integer Underflow (Wrap or Wraparound)"}],"description":"xrdp is an open source remote desktop protocol (RDP) server. In affected versions an integer underflow leading to a heap overflow in the sesman server allows any unauthenticated attacker which is able to locally access a sesman server to execute code as root. This vulnerability has been patched in version 0.9.18.1 and above. Users are advised to upgrade. There are no known workarounds.","ecosystems":["openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Privilege escalation on xrdp","id":"CVE-2022-23613","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"fedoraproject:fedora","products":["fedoraproject:fedora"],"type":"integer_overflow","year":"2022"},"n_packages":1,"n_references":4,"next":{"headline":"Code injection in Twig","id":"CVE-2022-23614"},"packages":[{"ecosystem":"openSUSE:Tumbleweed","fixed":["0.9.19-1.1"],"introduced":["0"],"last_affected":[],"package":"xrdp","purl":"pkg:rpm/opensuse/xrdp\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:12112-1"}],"prev":{"headline":"Directory Traversal in OpenMRS Startup Filter","id":"CVE-2022-23612"},"products":["xrdp"],"published":"2022-02-07","related":[{"cvss_score":9.8,"headline":"PHP-CGI OS Command Injection","id":"CVE-2024-4577","kev_date_added":"2024-06-12","published":"2024-06-09"},{"cvss_score":9.8,"headline":"Grafana Authentication Bypass","id":"CVE-2021-39226","kev_date_added":"2022-08-25","published":"2021-10-05"},{"cvss_score":9.8,"headline":"VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow","id":"CVE-2019-5544","kev_date_added":"2021-11-03","published":"2019-12-06"},{"cvss_score":9.6,"headline":"Google Chromium V8 Type Confusion","id":"CVE-2024-4947","kev_date_added":"2024-05-20","published":"2024-05-15"},{"cvss_score":9.6,"headline":"Google Chromium Visuals Use-After-Free","id":"CVE-2024-4671","kev_date_added":"2024-05-13","published":"2024-05-09"},{"cvss_score":9.6,"headline":"Google Chromium Mojo Insufficient Data Validation","id":"CVE-2022-3075","kev_date_added":"2022-09-08","published":"2022-09-26"},{"cvss_score":9.6,"headline":"Google Chromium Indexed DB API Use-After-Free","id":"CVE-2021-30633","kev_date_added":"2021-11-03","published":"2021-10-08"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-04-23","vendors":["neutrinolabs"]},"summary":"An integer underflow in xrdp sesman allows local unauthenticated attackers to execute code as root via heap overflow.","url":"https://insights.sbomify.com/CVE-2022-23613/"}