# CVE-2022-23613: Privilege escalation on xrdp

> An integer underflow in xrdp sesman allows local unauthenticated attackers to execute code as root via heap overflow.

- **Severity:** High 7.8 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Feb 2022
- **Updated:** 23 Apr 2025
- **Also known as:** DEBIAN-CVE-2022-23613, GHSA-8h98-h426-xf32, UBUNTU-CVE-2022-23613, openSUSE-SU-2024:12112-1

## What is CVE-2022-23613?

CVE-2022-23613 is a high-severity vulnerability in Fedoraproject Fedora, published on 7 Feb 2022. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

xrdp is an open source remote desktop protocol (RDP) server. In affected versions an integer underflow leading to a heap overflow in the sesman server allows any unauthenticated attacker which is able to locally access a sesman server to execute code as root. This vulnerability has been patched in version 0.9.18.1 and above. Users are advised to upgrade. There are no known workarounds.

Weakness: CWE-191 (Integer Underflow (Wrap or Wraparound))

## Which versions are affected by CVE-2022-23613?

It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `xrdp` | openSUSE:Tumbleweed | All versions | 0.9.19-1.1 |

Products: Fedoraproject Fedora, Neutrinolabs Xrdp.

## How do I fix CVE-2022-23613?

Upgrade to a fixed version.

## Is CVE-2022-23613 being exploited?

There is no known exploitation of CVE-2022-23613 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-23613 and fix it if it is affected.

What it is: CVE-2022-23613 is a high-severity vulnerability in Fedoraproject Fedora, published on 7 Feb 2022. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-23613 in the wild and no public exploit code.

Affected product: Fedoraproject Fedora. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-23613/ (Markdown: https://insights.sbomify.com/CVE-2022-23613/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-23613
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-23613
- OSV: https://osv.dev/vulnerability/CVE-2022-23613

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-23613/
Summaries are generated and may contain mistakes; the official description above is the record.
