CVE-2022-23615 Partial authorization bypass on document save in xwiki-platform

Medium 5.4 Published Updated

Users with SCRIPT rights can bypass authorization checks to save documents with elevated privileges, potentially accessing restricted APIs.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2022-23615?

CVE-2022-23615 is a medium-severity missing authorization vulnerability in Xwiki Xwiki, published on 9 Feb 2022. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. In affected versions any user with SCRIPT right can save a document with the right of the current user which allow accessing API requiring programming right if the current user has programming right. This has been patched in XWiki 13.0. Users are advised to update to resolve this issue. The only known workaround is to limit SCRIPT access.

Weakness: CWE-863

Which versions are affected by CVE-2022-23615?

2 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-oldcore. It affects 1 product.

PackageAffectedFixed in
org.xwiki.platform:xwiki-platform-oldcore MavenFrom 1.013.0
org.xwiki.platform:xwiki-platform-oldcore MavenFrom 1.013.0

Products include Xwiki Xwiki.

How do I fix CVE-2022-23615?

Upgrade org.xwiki.platform:xwiki-platform-oldcore to 13.0 or later.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2022-23615 being exploited?

There is no known exploitation of CVE-2022-23615 in the wild and no public exploit code.

All Xwiki Xwiki vulnerabilities

Sources

Also known as GHSA-f4cj-3q3h-884r.

Is CVE-2022-23615 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free