{"answers":{"affected":"2 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-oldcore. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-23615 in the wild and no public exploit code.","fix":"Upgrade org.xwiki.platform:xwiki-platform-oldcore to 13.0 or later.","what":"CVE-2022-23615 is a medium-severity missing authorization vulnerability in Xwiki Xwiki, published on 9 Feb 2022. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-23615 and fix it if it is affected.\n\nWhat it is: CVE-2022-23615 is a medium-severity missing authorization vulnerability in Xwiki Xwiki, published on 9 Feb 2022. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-23615 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected from 1.0; fixed in 13.0\n- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected from 1.0; fixed in 13.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-23615/ (Markdown: https://insights.sbomify.com/CVE-2022-23615/index.md)","id":"CVE-2022-23615","markdown":"https://insights.sbomify.com/CVE-2022-23615/index.md","name":"CVE-2022-23615","record":{"aliases":["GHSA-f4cj-3q3h-884r"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["privilege_escalation","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"XWiki platform","requires_auth":"low_privilege","summary":"Users with SCRIPT rights can bypass authorization checks to save documents with elevated privileges, potentially accessing restricted APIs.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"xwiki","vendor":"xwiki"}],"cvss":{"score":5.4,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-863","name":"Incorrect Authorization"}],"description":"XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. In affected versions any user with SCRIPT right can save a document with the right of the current user which allow accessing API requiring programming right if the current user has programming right. This has been patched in XWiki 13.0. Users are advised to update to resolve this issue. The only known workaround is to limit SCRIPT access.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Partial authorization bypass on document save in xwiki-platform","id":"CVE-2022-23615","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":"xwiki:xwiki","products":["xwiki:xwiki"],"type":"missing_authorization","year":"2022"},"n_packages":2,"n_references":3,"next":{"headline":"Remote code execution in xwiki-platform","id":"CVE-2022-23616"},"packages":[{"ecosystem":"Maven","fixed":["13.0"],"introduced":["1.0"],"last_affected":[],"package":"org.xwiki.platform:xwiki-platform-oldcore","purl":null,"source":"GHSA-f4cj-3q3h-884r"},{"ecosystem":"Maven","fixed":["13.0"],"introduced":["1.0"],"last_affected":[],"package":"org.xwiki.platform:xwiki-platform-oldcore","purl":"pkg:maven/org.xwiki.platform/xwiki-platform-oldcore","source":"GHSA-f4cj-3q3h-884r"}],"prev":{"headline":"Code injection in Twig","id":"CVE-2022-23614"},"products":["xwiki-platform"],"published":"2022-02-09","related":[{"cvss_score":9.8,"headline":"XWiki Platform Eval Injection","id":"CVE-2025-24893","kev_date_added":"2025-10-30","published":"2025-02-20"},{"cvss_score":10,"headline":"XWiki Rendering is vulnerable to RCE attacks when processing nested macros","id":"CVE-2025-53836","kev_date_added":null,"published":"2025-07-14"},{"cvss_score":10,"headline":"XWiki allows remote code execution through the extension sheet","id":"CVE-2024-55662","kev_date_added":null,"published":"2024-12-12"},{"cvss_score":10,"headline":"XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList","id":"CVE-2024-55877","kev_date_added":null,"published":"2024-12-12"},{"cvss_score":10,"headline":"XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet","id":"CVE-2024-37901","kev_date_added":null,"published":"2024-07-31"},{"cvss_score":10,"headline":"XWiki programming rights may be inherited by inclusion","id":"CVE-2024-38369","kev_date_added":null,"published":"2024-06-24"},{"cvss_score":10,"headline":"XWiki Platform: Remote code execution from account via SearchSuggestSourceSheet","id":"CVE-2024-31465","kev_date_added":null,"published":"2024-04-10"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-23","vendors":["xwiki"]},"summary":"Users with SCRIPT rights can bypass authorization checks to save documents with elevated privileges, potentially accessing restricted APIs.","url":"https://insights.sbomify.com/CVE-2022-23615/"}