# CVE-2022-23617: Missing authorization in xwiki-platform

> An attacker with edit rights can read content from pages they lack access to by using them as templates for new pages.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Feb 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-gf7x-2j2x-7f73

## What is CVE-2022-23617?

CVE-2022-23617 is a medium-severity missing authorization vulnerability in Xwiki Xwiki, published on 9 Feb 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. In affected versions any user with edit right can copy the content of a page it does not have access to by using it as template of a new page. This issue has been patched in XWiki 13.2CR1 and 12.10.6. Users are advised to update. There are no known workarounds for this issue.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2022-23617?

4 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-oldcore. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | All versions | 12.10.6 |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | All versions | 12.10.6 |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | From 13.0 | 13.2-rc-1 |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | From 13.0 | 13.2-rc-1 |

Products: Xwiki Xwiki.

## How do I fix CVE-2022-23617?

Upgrade org.xwiki.platform:xwiki-platform-oldcore to a fixed version for your release line: 12.10.6 or 13.2-rc-1.

## Is CVE-2022-23617 being exploited?

There is no known exploitation of CVE-2022-23617 in the wild and no public exploit code.

## Other vulnerabilities in Xwiki Xwiki

- [CVE-2025-24893](https://insights.sbomify.com/CVE-2025-24893/): XWiki Platform Eval Injection (critical 9.8, exploited in the wild)
- [CVE-2025-53836](https://insights.sbomify.com/CVE-2025-53836/): XWiki Rendering is vulnerable to RCE attacks when processing nested macros (critical 10.0)
- [CVE-2024-55662](https://insights.sbomify.com/CVE-2024-55662/): XWiki allows remote code execution through the extension sheet (critical 10.0)
- [CVE-2024-55877](https://insights.sbomify.com/CVE-2024-55877/): XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList (critical 10.0)
- [CVE-2024-37901](https://insights.sbomify.com/CVE-2024-37901/): XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-23617 and fix it if it is affected.

What it is: CVE-2022-23617 is a medium-severity missing authorization vulnerability in Xwiki Xwiki, published on 9 Feb 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-23617 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected all versions; fixed in 12.10.6
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected all versions; fixed in 12.10.6
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected from 13.0; fixed in 13.2-rc-1
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected from 13.0; fixed in 13.2-rc-1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-23617/ (Markdown: https://insights.sbomify.com/CVE-2022-23617/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-23617
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-23617
- OSV: https://osv.dev/vulnerability/CVE-2022-23617

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-23617/
Summaries are generated and may contain mistakes; the official description above is the record.
