# CVE-2022-23620: Path traversal in xwiki-platform-skin-skinx

> Attackers can exploit improper escaping in HTML export to traverse directories and read or modify files on the server.

- **Severity:** Medium 6.8 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:C/C:L/I:L/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 9 Feb 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-7ph6-5cmq-xgjq

## What is CVE-2022-23620?

CVE-2022-23620 is a medium-severity path traversal vulnerability in Xwiki Xwiki, published on 9 Feb 2022. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. In affected versions AbstractSxExportURLFactoryActionHandler#processSx does not escape anything from SSX document references when serializing it on filesystem, it is possible to for the HTML export process to contain reference elements containing filesystem syntax like "../", "./". or "/" in general. The referenced elements are not properly escaped. This issue has been resolved in version 13.6-rc-1. This issue can be worked around by limiting or disabling document export.

Weakness: CWE-116 (Improper Encoding or Escaping of Output), CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2022-23620?

2 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-skin-skinx. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.platform:xwiki-platform-skin-skinx` | Maven | From 6.2-rc-1 | 13.6 |
| `org.xwiki.platform:xwiki-platform-skin-skinx` | Maven | From 6.2-rc-1 | 13.6 |

Products: Xwiki Xwiki.

## How do I fix CVE-2022-23620?

Upgrade org.xwiki.platform:xwiki-platform-skin-skinx to 13.6 or later.

## Is CVE-2022-23620 being exploited?

There is no known exploitation of CVE-2022-23620 in the wild and no public exploit code.

## Other vulnerabilities in Xwiki Xwiki

- [CVE-2025-24893](https://insights.sbomify.com/CVE-2025-24893/): XWiki Platform Eval Injection (critical 9.8, exploited in the wild)
- [CVE-2025-53836](https://insights.sbomify.com/CVE-2025-53836/): XWiki Rendering is vulnerable to RCE attacks when processing nested macros (critical 10.0)
- [CVE-2024-55662](https://insights.sbomify.com/CVE-2024-55662/): XWiki allows remote code execution through the extension sheet (critical 10.0)
- [CVE-2024-55877](https://insights.sbomify.com/CVE-2024-55877/): XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList (critical 10.0)
- [CVE-2024-37901](https://insights.sbomify.com/CVE-2024-37901/): XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-23620 and fix it if it is affected.

What it is: CVE-2022-23620 is a medium-severity path traversal vulnerability in Xwiki Xwiki, published on 9 Feb 2022. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-23620 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.xwiki.platform:xwiki-platform-skin-skinx (Maven): affected from 6.2-rc-1; fixed in 13.6
- org.xwiki.platform:xwiki-platform-skin-skinx (Maven): affected from 6.2-rc-1; fixed in 13.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-23620/ (Markdown: https://insights.sbomify.com/CVE-2022-23620/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-23620
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-23620
- OSV: https://osv.dev/vulnerability/CVE-2022-23620

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-23620/
Summaries are generated and may contain mistakes; the official description above is the record.
