# CVE-2022-23621: Missing authorization in xwiki-platform

> Users with SCRIPT rights can read sensitive configuration files from the web application directory due to missing authorization checks.

- **Severity:** Medium 5.5 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:L/I:L/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Feb 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-2jhm-qp48-hv5j

## What is CVE-2022-23621?

CVE-2022-23621 is a medium-severity missing authorization vulnerability in Xwiki Xwiki, published on 9 Feb 2022. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. In affected versions any user with SCRIPT right can read any file located in the XWiki WAR (for example xwiki.cfg and xwiki.properties) through XWiki#invokeServletAndReturnAsString as `$xwiki.invokeServletAndReturnAsString("/WEB-INF/xwiki.cfg")`. This issue has been patched in XWiki versions 12.10.9, 13.4.3 and 13.7-rc-1. Users are advised to update. The only workaround is to limit SCRIPT right.

Weakness: CWE-552 (Files or Directories Accessible to External Parties), CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2022-23621?

6 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-oldcore. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | All versions | 12.10.9 |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | All versions | 12.10.9 |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | From 13.0.0 | 13.4.3 |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | From 13.0.0 | 13.4.3 |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | From 13.6-rc-1 | 13.7-rc-1 |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | From 13.6-rc-1 | 13.7-rc-1 |

Products: Xwiki Xwiki.

## How do I fix CVE-2022-23621?

Upgrade org.xwiki.platform:xwiki-platform-oldcore to a fixed version for your release line: 12.10.9, 13.4.3 or 13.7-rc-1.

## Is CVE-2022-23621 being exploited?

There is no known exploitation of CVE-2022-23621 in the wild and no public exploit code.

## Other vulnerabilities in Xwiki Xwiki

- [CVE-2025-24893](https://insights.sbomify.com/CVE-2025-24893/): XWiki Platform Eval Injection (critical 9.8, exploited in the wild)
- [CVE-2025-53836](https://insights.sbomify.com/CVE-2025-53836/): XWiki Rendering is vulnerable to RCE attacks when processing nested macros (critical 10.0)
- [CVE-2024-55662](https://insights.sbomify.com/CVE-2024-55662/): XWiki allows remote code execution through the extension sheet (critical 10.0)
- [CVE-2024-55877](https://insights.sbomify.com/CVE-2024-55877/): XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList (critical 10.0)
- [CVE-2024-37901](https://insights.sbomify.com/CVE-2024-37901/): XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-23621 and fix it if it is affected.

What it is: CVE-2022-23621 is a medium-severity missing authorization vulnerability in Xwiki Xwiki, published on 9 Feb 2022. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-23621 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected all versions; fixed in 12.10.9
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected all versions; fixed in 12.10.9
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected from 13.0.0; fixed in 13.4.3
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected from 13.0.0; fixed in 13.4.3
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected from 13.6-rc-1; fixed in 13.7-rc-1
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected from 13.6-rc-1; fixed in 13.7-rc-1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-23621/ (Markdown: https://insights.sbomify.com/CVE-2022-23621/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-23621
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-23621
- OSV: https://osv.dev/vulnerability/CVE-2022-23621

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-23621/
Summaries are generated and may contain mistakes; the official description above is the record.
