# CVE-2022-23622: Cross site scripting in registration template in xwiki-platform

> Attacker can execute arbitrary scripts via XSS in registration template if wiki is open to registration but restricts guest viewing.

- **Severity:** High 7.4 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 9 Feb 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-gx6h-936c-vrrr

## What is CVE-2022-23622?

CVE-2022-23622 is a high-severity cross-site scripting vulnerability in Xwiki Xwiki, published on 9 Feb 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. In affected versions there is a cross site scripting (XSS) vector in the `registerinline.vm` template related to the `xredirect` hidden field. This template is only used in the following conditions: 1. The wiki must be open to registration for anyone. 2. The wiki must be closed to view for Guest users or more specifically the XWiki.Registration page must be forbidden in View for guest user. A way to obtain the second condition is when administrators checked the "Prevent unregistered users from viewing pages, regardless of the page rights" box in the administration rights. This issue is patched in versions 12.10.11, 14.0-rc-1, 13.4.7, 13.10.3. There are two main ways for protecting against this vulnerability, the easiest and the best one is by applying a patch in the `registerinline.vm` template, the patch consists in checking the value of the xredirect field to ensure it matches: `<input type="hidden" name="xredirect" value="$escapetool.xml($!request.xredirect)" />`. If for some reason it's not possible to patch this file, another workaround is to ensure "Prevent unregistered users from viewing pages, regardless of the page rights" is not checked in the rights and apply a better right scheme using groups and rights on spaces.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2022-23622?

6 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-web-templates. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.platform:xwiki-platform-web-templates` | Maven | From 13.0.0 | 13.4.7 |
| `org.xwiki.platform:xwiki-platform-web-templates` | Maven | From 13.0.0 | 13.4.7 |
| `org.xwiki.platform:xwiki-platform-web-templates` | Maven | From 13.10.0 | 13.10.3 |
| `org.xwiki.platform:xwiki-platform-web-templates` | Maven | From 13.10.0 | 13.10.3 |
| `org.xwiki.platform:xwiki-platform-web-templates` | Maven | From 2.6.1 | 12.10.11 |
| `org.xwiki.platform:xwiki-platform-web-templates` | Maven | From 2.6.1 | 12.10.11 |

Products: Xwiki Xwiki.

## How do I fix CVE-2022-23622?

Upgrade org.xwiki.platform:xwiki-platform-web-templates to a fixed version for your release line: 13.4.7, 13.10.3 or 12.10.11.

## Is CVE-2022-23622 being exploited?

There is no known exploitation of CVE-2022-23622 in the wild and no public exploit code.

## Other vulnerabilities in Xwiki Xwiki

- [CVE-2025-24893](https://insights.sbomify.com/CVE-2025-24893/): XWiki Platform Eval Injection (critical 9.8, exploited in the wild)
- [CVE-2025-53836](https://insights.sbomify.com/CVE-2025-53836/): XWiki Rendering is vulnerable to RCE attacks when processing nested macros (critical 10.0)
- [CVE-2024-55662](https://insights.sbomify.com/CVE-2024-55662/): XWiki allows remote code execution through the extension sheet (critical 10.0)
- [CVE-2024-55877](https://insights.sbomify.com/CVE-2024-55877/): XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList (critical 10.0)
- [CVE-2024-37901](https://insights.sbomify.com/CVE-2024-37901/): XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-23622 and fix it if it is affected.

What it is: CVE-2022-23622 is a high-severity cross-site scripting vulnerability in Xwiki Xwiki, published on 9 Feb 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-23622 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.xwiki.platform:xwiki-platform-web-templates (Maven): affected from 13.0.0; fixed in 13.4.7
- org.xwiki.platform:xwiki-platform-web-templates (Maven): affected from 13.0.0; fixed in 13.4.7
- org.xwiki.platform:xwiki-platform-web-templates (Maven): affected from 13.10.0; fixed in 13.10.3
- org.xwiki.platform:xwiki-platform-web-templates (Maven): affected from 13.10.0; fixed in 13.10.3
- org.xwiki.platform:xwiki-platform-web-templates (Maven): affected from 2.6.1; fixed in 12.10.11
- org.xwiki.platform:xwiki-platform-web-templates (Maven): affected from 2.6.1; fixed in 12.10.11

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-23622/ (Markdown: https://insights.sbomify.com/CVE-2022-23622/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-23622
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-23622
- OSV: https://osv.dev/vulnerability/CVE-2022-23622

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-23622/
Summaries are generated and may contain mistakes; the official description above is the record.
