{"answers":{"affected":"2 open source packages ship an affected version, including frourio-express. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-23624 in the wild and no public exploit code.","fix":"Upgrade frourio-express to 0.26.0 or later.","what":"CVE-2022-23624 is a high-severity missing authorization vulnerability in frouriojs frourio-express, published on 7 Feb 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-23624 and fix it if it is affected.\n\nWhat it is: CVE-2022-23624 is a high-severity missing authorization vulnerability in frouriojs frourio-express, published on 7 Feb 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-23624 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- frourio-express (npm): affected all versions; fixed in 0.26.0\n- frourio-express (npm): affected all versions; fixed in 0.26.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-23624/ (Markdown: https://insights.sbomify.com/CVE-2022-23624/index.md)","id":"CVE-2022-23624","markdown":"https://insights.sbomify.com/CVE-2022-23624/index.md","name":"CVE-2022-23624","record":{"aliases":["GHSA-mmj4-777p-fpq9"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"TypeScript web framework","requires_auth":"none","summary":"Attackers can bypass input validation in frourio-express when using class-validator, potentially leading to unauthorized actions or data manipulation.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"frourio-express","vendor":"frourio"}],"cvss":{"score":8.1,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-1321","name":"Improperly Controlled Modification of Object Prototype Attributes"},{"id":"CWE-20","name":"Improper Input Validation"}],"description":"Frourio-express is a minimal full stack framework, for TypeScript. Frourio-express users who uses frourio-express version prior to v0.26.0 and integration with class-validator through `validators/` folder are subject to a input validation vulnerability. Validators do not work properly for request bodies and queries in specific situations and some input is not validated at all. Users are advised to update frourio to v0.26.0 or later and to install `class-transformer` and `reflect-metadata`.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Validation bypass in frourio-express","id":"CVE-2022-23624","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"missing_authorization","year":"2022"},"n_packages":2,"n_references":2,"next":{"headline":"DoS vulnerability: Malformed Resource Identifiers","id":"CVE-2022-23625"},"packages":[{"ecosystem":"npm","fixed":["0.26.0"],"introduced":["0"],"last_affected":[],"package":"frourio-express","purl":null,"source":"GHSA-mmj4-777p-fpq9"},{"ecosystem":"npm","fixed":["0.26.0"],"introduced":["0"],"last_affected":[],"package":"frourio-express","purl":"pkg:npm/frourio-express","source":"GHSA-mmj4-777p-fpq9"}],"prev":{"headline":"Validation bypass in frourio","id":"CVE-2022-23623"},"products":["frourio-express"],"published":"2022-02-07","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-04-23","vendors":["frouriojs"]},"summary":"Attackers can bypass input validation in frourio-express when using class-validator, potentially leading to unauthorized actions or data manipulation.","url":"https://insights.sbomify.com/CVE-2022-23624/"}