# CVE-2022-23624: Validation bypass in frourio-express

> Attackers can bypass input validation in frourio-express when using class-validator, potentially leading to unauthorized actions or data manipulation.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Feb 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-mmj4-777p-fpq9

## What is CVE-2022-23624?

CVE-2022-23624 is a high-severity missing authorization vulnerability in frouriojs frourio-express, published on 7 Feb 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Frourio-express is a minimal full stack framework, for TypeScript. Frourio-express users who uses frourio-express version prior to v0.26.0 and integration with class-validator through `validators/` folder are subject to a input validation vulnerability. Validators do not work properly for request bodies and queries in specific situations and some input is not validated at all. Users are advised to update frourio to v0.26.0 or later and to install `class-transformer` and `reflect-metadata`.

Weakness: CWE-1321 (Improperly Controlled Modification of Object Prototype Attributes), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2022-23624?

2 open source packages ship an affected version, including frourio-express. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `frourio-express` | npm | All versions | 0.26.0 |
| `frourio-express` | npm | All versions | 0.26.0 |

Products: Frourio Frourio-Express.

## How do I fix CVE-2022-23624?

Upgrade frourio-express to 0.26.0 or later.

## Is CVE-2022-23624 being exploited?

There is no known exploitation of CVE-2022-23624 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-23624 and fix it if it is affected.

What it is: CVE-2022-23624 is a high-severity missing authorization vulnerability in frouriojs frourio-express, published on 7 Feb 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-23624 in the wild and no public exploit code.

Affected packages and fixed versions:
- frourio-express (npm): affected all versions; fixed in 0.26.0
- frourio-express (npm): affected all versions; fixed in 0.26.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-23624/ (Markdown: https://insights.sbomify.com/CVE-2022-23624/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-23624
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-23624
- OSV: https://osv.dev/vulnerability/CVE-2022-23624

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-23624/
Summaries are generated and may contain mistakes; the official description above is the record.
