# CVE-2022-23627: Inadequate access verification when using proxy commands in ArchiSteamFarm

> An attacker with control over one bot can access resources of other bots due to inadequate access verification in proxy commands.

- **Severity:** Medium 5.0 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 8 Feb 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-88ch-366c-5m89

## What is CVE-2022-23627?

CVE-2022-23627 is a medium-severity missing authorization vulnerability in JustArchiNET ArchiSteamFarm, published on 8 Feb 2022. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

ArchiSteamFarm (ASF) is a C# application with primary purpose of idling Steam cards from multiple accounts simultaneously. Due to a bug in ASF code, introduced in version V5.2.2.2, the program didn't adequately verify effective access of the user sending proxy (i.e. `[Bots]`) commands. In particular, a proxy-like command sent to bot `A` targeting bot `B` has incorrectly verified user's access against bot `A` - instead of bot `B`, to which the command was originally designated. This in result allowed access to resources beyond those configured, being a security threat affecting confidentiality of other bot instances. A successful attack exploiting this bug requires a significant access granted explicitly by original owner of the ASF process prior to that, as attacker has to control at least a single bot in the process to make use of this inadequate access verification loophole. The issue is patched in ASF V5.2.2.5, V5.2.3.2 and future versions. Users are advised to update as soon as possible.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2022-23627?

It affects 1 product.


Products: Archisteamfarm Project Archisteamfarm.

## How do I fix CVE-2022-23627?

No fix has been published for CVE-2022-23627 yet. Limit exposure of the affected software until one is available.

## Is CVE-2022-23627 being exploited?

There is no known exploitation of CVE-2022-23627 in the wild and no public exploit code.

## Other vulnerabilities in JustArchiNET ArchiSteamFarm

- [CVE-2021-32794](https://insights.sbomify.com/CVE-2021-32794/): Accidental removal of IPCPassword (< 5.1.2.4) (medium 6.8)
- [CVE-2021-32795](https://insights.sbomify.com/CVE-2021-32795/): Denial of Service via Steam chat in ArchiSteamFarm (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-23627 and fix it if it is affected.

What it is: CVE-2022-23627 is a medium-severity missing authorization vulnerability in JustArchiNET ArchiSteamFarm, published on 8 Feb 2022. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-23627 in the wild and no public exploit code.

Affected product: JustArchiNET ArchiSteamFarm. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-23627/ (Markdown: https://insights.sbomify.com/CVE-2022-23627/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-23627
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-23627
- OSV: https://osv.dev/vulnerability/CVE-2022-23627

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-23627/
Summaries are generated and may contain mistakes; the official description above is the record.
