# CVE-2022-23628: Array literal misordering in github.com/open-policy-agent/opa

> Attackers can bypass policy logic by exploiting array reordering during AST pretty-printing in optimized bundles, affecting policy enforcement integrity.

- **Severity:** Medium 6.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Feb 2022
- **Updated:** 22 Apr 2025
- **Also known as:** GHSA-hcw3-j74m-qc58, GO-2022-0316

## What is CVE-2022-23628?

CVE-2022-23628 is a medium-severity vulnerability in open-policy-agent opa, published on 9 Feb 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

OPA is an open source, general-purpose policy engine. Under certain conditions, pretty-printing an abstract syntax tree (AST) that contains synthetic nodes could change the logic of some statements by reordering array literals. Example of policies impacted are those that parse and compare web paths. **All of these** three conditions have to be met to create an adverse effect: 1. An AST of Rego had to be **created programmatically** such that it ends up containing terms without a location (such as wildcard variables). 2. The AST had to be **pretty-printed** using the `github.com/open-policy-agent/opa/format` package. 3. The result of the pretty-printing had to be **parsed and evaluated again** via an OPA instance using the bundles, or the Golang packages. If any of these three conditions are not met, you are not affected. Notably, all three would be true if using **optimized bundles**, i.e. bundles created with `opa build -O=1` or higher. In that case, the optimizer would fulfil condition (1.), the result of that would be pretty-printed when writing the bundle to disk, fulfilling (2.). When the bundle was then used, we'd satisfy (3.). As a workaround users may disable optimization when creating bundles.

Weakness: CWE-682 (Incorrect Calculation)

## Which versions are affected by CVE-2022-23628?

3 open source packages ship an affected version, including github.com/open-policy-agent/opa. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/open-policy-agent/opa` | Go | From 0.33.1 | 0.37.2 |
| `github.com/open-policy-agent/opa` | Go | From 0.33.1 | 0.37.2 |
| `github.com/open-policy-agent/opa` | Go | From 0.33.1 | 0.37.2 |

Products: Openpolicyagent Open Policy Agent.

## How do I fix CVE-2022-23628?

Upgrade github.com/open-policy-agent/opa to 0.37.2 or later.

## Is CVE-2022-23628 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-23628 exists.

## Other vulnerabilities in open-policy-agent opa

- [CVE-2022-33082](https://insights.sbomify.com/CVE-2022-33082/): Denial of service in Open Policy Agent (high 7.5)
- [CVE-2022-28946](https://insights.sbomify.com/CVE-2022-28946/): Out of bounds memory access in github.com/open-policy-agent/opa (high 7.5)
- [CVE-2022-36085](https://insights.sbomify.com/CVE-2022-36085/): OPA Compiler: Bypass of WithUnsafeBuiltins using `with` keyword to mock functions (high 7.4)
- [CVE-2024-8260](https://insights.sbomify.com/CVE-2024-8260/): OPA SMB Force-Authentication (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-23628 and fix it if it is affected.

What it is: CVE-2022-23628 is a medium-severity vulnerability in open-policy-agent opa, published on 9 Feb 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-23628 exists.

Affected packages and fixed versions:
- github.com/open-policy-agent/opa (Go): affected from 0.33.1; fixed in 0.37.2
- github.com/open-policy-agent/opa (Go): affected from 0.33.1; fixed in 0.37.2
- github.com/open-policy-agent/opa (Go): affected from 0.33.1; fixed in 0.37.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-23628/ (Markdown: https://insights.sbomify.com/CVE-2022-23628/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-23628
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-23628
- OSV: https://osv.dev/vulnerability/CVE-2022-23628

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-23628/
Summaries are generated and may contain mistakes; the official description above is the record.
