{"answers":{"affected":"1 open source package ship an affected version, including gradle. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-23630 in the wild and no public exploit code.","fix":"Upgrade gradle to 7.3.4 or later.","what":"CVE-2022-23630 is a high-severity vulnerability in gradle, published on 10 Feb 2022. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-23630 and fix it if it is affected.\n\nWhat it is: CVE-2022-23630 is a high-severity vulnerability in gradle, published on 10 Feb 2022. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-23630 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- gradle (Bitnami): affected from 6.2.0; fixed in 7.3.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-23630/ (Markdown: https://insights.sbomify.com/CVE-2022-23630/index.md)","id":"CVE-2022-23630","markdown":"https://insights.sbomify.com/CVE-2022-23630/index.md","name":"CVE-2022-23630","record":{"aliases":["BIT-gradle-2022-23630","GHSA-9pf5-88jw-3qgr","UBUNTU-CVE-2022-23630"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"Gradle build tool","requires_auth":"low_privilege","summary":"Gradle may skip dependency verification for shared artifacts if one configuration disables it, allowing untrusted dependencies to be accepted.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"gradle","vendor":"gradle"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-829","name":"Inclusion of Functionality from Untrusted Control Sphere"}],"description":"Gradle is a build tool with a focus on build automation and support for multi-language development. In some cases, Gradle may skip that verification and accept a dependency that would otherwise fail the build as an untrusted external artifact. This occurs when dependency verification is disabled on one or more configurations and those configurations have common dependencies with other configurations that have dependency verification enabled. If the configuration that has dependency verification disabled is resolved first, Gradle does not verify the common dependencies for the configuration that has dependency verification enabled. Gradle 7.4 fixes that issue by validating artifacts at least once if they are present in a resolved configuration that has dependency verification active. For users who cannot update either do not use `ResolutionStrategy.disableDependencyVerification()` and do not use plugins that use that method to disable dependency verification for a single configuration or make sure resolution of configuration that disable that feature do not happen in builds that resolve configuration where the feature is enabled.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Dependency verification bypass in Gradle","id":"CVE-2022-23630","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"security_feature_bypass","year":"2022"},"n_packages":1,"n_references":3,"next":{"headline":"Prototype Pollution leading to Remote Code Execution in superjson","id":"CVE-2022-23631"},"packages":[{"ecosystem":"Bitnami","fixed":["7.3.4"],"introduced":["6.2.0"],"last_affected":[],"package":"gradle","purl":"pkg:bitnami/gradle","source":"BIT-gradle-2022-23630"}],"prev":{"headline":"Array literal misordering in github.com/open-policy-agent/opa","id":"CVE-2022-23628"},"products":["gradle"],"published":"2022-02-10","related":[{"cvss_score":9.8,"headline":"Information disclosure in n/a","id":"CVE-2019-15052","kev_date_added":null,"published":"2019-08-14"},{"cvss_score":9.8,"headline":"Deserialization in n/a","id":"CVE-2016-6199","kev_date_added":null,"published":"2017-02-07"},{"cvss_score":8.8,"headline":"Local privilege escalation through system temporary directory","id":"CVE-2021-29428","kev_date_added":null,"published":"2021-04-13"},{"cvss_score":8.6,"headline":"Gradle fails to disable repositories which can expose builds to malicious artifacts","id":"CVE-2026-22816","kev_date_added":null,"published":"2026-01-16"},{"cvss_score":8.6,"headline":"Gradle's failure to disable repositories failing to answer can expose builds to malicious artifacts","id":"CVE-2026-22865","kev_date_added":null,"published":"2026-01-16"},{"cvss_score":8.1,"headline":"Deserialization in n/a","id":"CVE-2021-41588","kev_date_added":null,"published":"2021-09-24"},{"cvss_score":8,"headline":"Repository content filters do not work in Settings pluginManagement","id":"CVE-2021-29427","kev_date_added":null,"published":"2021-04-13"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-04-23","vendors":["gradle"]},"summary":"Gradle may skip dependency verification for shared artifacts if one configuration disables it, allowing untrusted dependencies to be accepted.","url":"https://insights.sbomify.com/CVE-2022-23630/"}