# CVE-2022-23631: Prototype Pollution leading to Remote Code Execution in superjson


- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 9 Feb 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-5888-ffcr-r425

## What is CVE-2022-23631?

CVE-2022-23631 is a critical vulnerability in blitz-js superjson, published on 9 Feb 2022. 

### Official description

superjson is a program to allow JavaScript expressions to be serialized to a superset of JSON. In versions prior to 1.8.1 superjson allows input to run arbitrary code on any server using superjson input without prior authentication or knowledge. The only requirement is that the server implements at least one endpoint which uses superjson during request processing. This has been patched in superjson 1.8.1. Users are advised to update. There are no known workarounds for this issue.

Weakness: CWE-1321 (Improperly Controlled Modification of Object Prototype Attributes), CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2022-23631?

4 open source packages ship an affected version, including superjson and blitz. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `superjson` | npm | All versions | 1.8.1 |
| `superjson` | npm | All versions | 1.8.1 |
| `blitz` | npm | All versions | 0.45.3 |
| `blitz` | npm | All versions | 0.45.3 |

Products: Blitzjs Blitz, Blitzjs Superjson.

## How do I fix CVE-2022-23631?

Upgrade superjson to 1.8.1 or later.

## Is CVE-2022-23631 being exploited?

There is no known exploitation of CVE-2022-23631 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-23631 and fix it if it is affected.

What it is: CVE-2022-23631 is a critical vulnerability in blitz-js superjson, published on 9 Feb 2022. 
Exploitation: There is no known exploitation of CVE-2022-23631 in the wild and no public exploit code.

Affected packages and fixed versions:
- superjson (npm): affected all versions; fixed in 1.8.1
- superjson (npm): affected all versions; fixed in 1.8.1
- blitz (npm): affected all versions; fixed in 0.45.3
- blitz (npm): affected all versions; fixed in 0.45.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-23631/ (Markdown: https://insights.sbomify.com/CVE-2022-23631/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-23631
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-23631
- OSV: https://osv.dev/vulnerability/CVE-2022-23631

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-23631/
Summaries are generated and may contain mistakes; the official description above is the record.
