# CVE-2022-23632: Traefik skips the router TLS configuration when the host header is an FQDN

> Traefik may apply incorrect TLS configurations when handling FQDN host headers, potentially bypassing intended security settings.

- **Severity:** High 7.4 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Feb 2022
- **Updated:** 23 Apr 2025
- **Also known as:** ECHO-066f-5a18-8f31, GHSA-hrhx-6h34-j5hc, GO-2022-0325

## What is CVE-2022-23632?

CVE-2022-23632 is a high-severity vulnerability in Oracle Communications Unified Inventory Management, published on 17 Feb 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Traefik is an HTTP reverse proxy and load balancer. Prior to version 2.6.1, Traefik skips the router transport layer security (TLS) configuration when the host header is a fully qualified domain name (FQDN). For a request, the TLS configuration choice can be different than the router choice, which implies the use of a wrong TLS configuration. When sending a request using FQDN handled by a router configured with a dedicated TLS configuration, the TLS configuration falls back to the default configuration that might not correspond to the configured one. If the CNAME flattening is enabled, the selected TLS configuration is the SNI one and the routing uses the CNAME value, so this can skip the expected TLS configuration. Version 2.6.1 contains a patch for this issue. As a workaround, one may add the FDQN to the host rule. However, there is no workaround if the CNAME flattening is enabled.

Weakness: CWE-295 (Improper Certificate Validation)

## Which versions are affected by CVE-2022-23632?

4 open source packages ship an affected version, including github.com/traefik/traefik/v2 and github.com/traefik/traefik. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/traefik/traefik/v2` | Go | All versions | 2.6.1 |
| `github.com/traefik/traefik/v2` | Go | All versions | 2.6.1 |
| `github.com/traefik/traefik/v2` | Go | All versions | 2.6.1 |
| `github.com/traefik/traefik` | Go | All versions | None |

Products: Oracle Communications Unified Inventory Management, Traefik Traefik.

## How do I fix CVE-2022-23632?

Upgrade github.com/traefik/traefik/v2 to 2.6.1 or later.

## Is CVE-2022-23632 being exploited?

There is no known exploitation of CVE-2022-23632 in the wild and no public exploit code.

## Other vulnerabilities in Oracle Communications Unified Inventory Management

- [CVE-2026-71142](https://insights.sbomify.com/CVE-2026-71142/): Missing authorization in Oracle Communications Unified Inventory Management (high 7.5)
- [CVE-2026-71143](https://insights.sbomify.com/CVE-2026-71143/): Missing authorization in Oracle Communications Unified Inventory Management (high 7.4)
- [CVE-2026-61095](https://insights.sbomify.com/CVE-2026-61095/): Missing authorization in Oracle Communications Unified Inventory Management (high 7.1)
- [CVE-2018-2570](https://insights.sbomify.com/CVE-2018-2570/): Missing authorization in Communications Unified Inventory Management (medium 6.3)
- [CVE-2018-2571](https://insights.sbomify.com/CVE-2018-2571/): Missing authorization in Communications Unified Inventory Management (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-23632 and fix it if it is affected.

What it is: CVE-2022-23632 is a high-severity vulnerability in Oracle Communications Unified Inventory Management, published on 17 Feb 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-23632 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/traefik/traefik/v2 (Go): affected all versions; fixed in 2.6.1
- github.com/traefik/traefik/v2 (Go): affected all versions; fixed in 2.6.1
- github.com/traefik/traefik/v2 (Go): affected all versions; fixed in 2.6.1
- github.com/traefik/traefik (Go): affected all versions; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-23632/ (Markdown: https://insights.sbomify.com/CVE-2022-23632/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-23632
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-23632
- OSV: https://osv.dev/vulnerability/CVE-2022-23632

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-23632/
Summaries are generated and may contain mistakes; the official description above is the record.
