CVE-2022-23634 Information Exposure when using Puma with Rails

High 8.0 Published Updated

Attackers can access leaked information due to improper response body closure in Puma when used with Rails, requiring an upgrade to patched versions.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2022-23634?

CVE-2022-23634 is a high-severity vulnerability in Debian Debian Linux, published on 11 Feb 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

Puma is a Ruby/Rack web server built for parallelism. Prior to `puma` version `5.6.2`, `puma` may not always call `close` on the response body. Rails, prior to version `7.0.2.2`, depended on the response body being closed in order for its `CurrentAttributes` implementation to work correctly. The combination of these two behaviors (Puma not closing the body + Rails' Executor implementation) causes information leakage. This problem is fixed in Puma versions 5.6.2 and 4.3.11. This problem is fixed in Rails versions 7.02.2, 6.1.4.6, 6.0.4.6, and 5.2.6.2. Upgrading to a patched Rails _or_ Puma version fixes the vulnerability.

Weakness: CWE-404, CWE-200

Which versions are affected by CVE-2022-23634?

4 open source packages ship an affected version, including puma. It affects 4 products.

PackageAffectedFixed in
puma RubyGemsAll versions4.3.11
puma RubyGemsAll versions4.3.11
puma RubyGemsFrom 5.0.05.6.2
puma RubyGemsFrom 5.0.05.6.2

Products include Debian Debian Linux, Fedoraproject Fedora, Puma Puma, Rubyonrails Rails.

How do I fix CVE-2022-23634?

Upgrade puma to a fixed version for your release line: 4.3.11 or 5.6.2.

Is CVE-2022-23634 being exploited?

There is no known exploitation of CVE-2022-23634 in the wild and no public exploit code.

All Debian Debian Linux vulnerabilities

Sources

Also known as DEBIAN-CVE-2022-23634, GHSA-rmj8-8hhh-gv5h, OESA-2024-1002, OESA-2024-1003, OESA-2024-1004, OESA-2024-1005 and 2 more.

Is CVE-2022-23634 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free