{"answers":{"affected":"4 open source packages ship an affected version, including puma. It affects 4 products.","exploited":"There is no known exploitation of CVE-2022-23634 in the wild and no public exploit code.","fix":"Upgrade puma to a fixed version for your release line: 4.3.11 or 5.6.2.","what":"CVE-2022-23634 is a high-severity vulnerability in Debian Debian Linux, published on 11 Feb 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-23634 and fix it if it is affected.\n\nWhat it is: CVE-2022-23634 is a high-severity vulnerability in Debian Debian Linux, published on 11 Feb 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2022-23634 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- puma (RubyGems): affected all versions; fixed in 4.3.11\n- puma (RubyGems): affected all versions; fixed in 4.3.11\n- puma (RubyGems): affected from 5.0.0; fixed in 5.6.2\n- puma (RubyGems): affected from 5.0.0; fixed in 5.6.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-23634/ (Markdown: https://insights.sbomify.com/CVE-2022-23634/index.md)","id":"CVE-2022-23634","markdown":"https://insights.sbomify.com/CVE-2022-23634/index.md","name":"CVE-2022-23634","record":{"aliases":["DEBIAN-CVE-2022-23634","GHSA-rmj8-8hhh-gv5h","OESA-2024-1002","OESA-2024-1003","OESA-2024-1004","OESA-2024-1005","OESA-2024-1007","UBUNTU-CVE-2022-23634"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby web server","requires_auth":"none","summary":"Attackers can access leaked information due to improper response body closure in Puma when used with Rails, requiring an upgrade to patched versions.","user_interaction":"required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"debian_linux","vendor":"debian"},{"product":"fedora","vendor":"fedoraproject"},{"product":"puma","vendor":"puma"},{"product":"rails","vendor":"rubyonrails"}],"cvss":{"score":8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-404","name":"Improper Resource Shutdown or Release"},{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"}],"description":"Puma is a Ruby/Rack web server built for parallelism. Prior to `puma` version `5.6.2`, `puma` may not always call `close` on the response body. Rails, prior to version `7.0.2.2`, depended on the response body being closed in order for its `CurrentAttributes` implementation to work correctly. The combination of these two behaviors (Puma not closing the body + Rails' Executor implementation) causes information leakage. This problem is fixed in Puma versions 5.6.2 and 4.3.11. This problem is fixed in Rails versions 7.02.2, 6.1.4.6, 6.0.4.6, and 5.2.6.2. Upgrading to a patched Rails _or_ Puma version fixes the vulnerability.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Information Exposure when using Puma with Rails","id":"CVE-2022-23634","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":"debian:debian_linux","products":["debian:debian_linux","fedoraproject:fedora","rubyonrails:rails"],"type":"information_disclosure","year":"2022"},"n_packages":4,"n_references":12,"next":{"headline":"Unauthenticated control plane denial of service attack in Istio","id":"CVE-2022-23635"},"packages":[{"ecosystem":"RubyGems","fixed":["4.3.11"],"introduced":["0"],"last_affected":[],"package":"puma","purl":null,"source":"GHSA-rmj8-8hhh-gv5h"},{"ecosystem":"RubyGems","fixed":["4.3.11"],"introduced":["0"],"last_affected":[],"package":"puma","purl":"pkg:gem/puma","source":"GHSA-rmj8-8hhh-gv5h"},{"ecosystem":"RubyGems","fixed":["5.6.2"],"introduced":["5.0.0"],"last_affected":[],"package":"puma","purl":null,"source":"GHSA-rmj8-8hhh-gv5h"},{"ecosystem":"RubyGems","fixed":["5.6.2"],"introduced":["5.0.0"],"last_affected":[],"package":"puma","purl":"pkg:gem/puma","source":"GHSA-rmj8-8hhh-gv5h"}],"prev":{"headline":"Exposure of sensitive information in Action Pack","id":"CVE-2022-23633"},"products":["puma"],"published":"2022-02-11","related":[{"cvss_score":10,"headline":"ProFTPD Improper Access Control","id":"CVE-2015-3306","kev_date_added":"2026-10-08","published":"2015-05-18"},{"cvss_score":9.9,"headline":"RoundCube Webmail Deserialization of Untrusted Data","id":"CVE-2025-49113","kev_date_added":"2026-02-20","published":"2025-06-02"},{"cvss_score":9.8,"headline":"GNU InetUtils Argument Injection","id":"CVE-2026-24061","kev_date_added":"2026-01-26","published":"2026-01-21"},{"cvss_score":9.8,"headline":"Linux Kernel Improper Check for Unusual or Exceptional Conditions","id":"CVE-2025-39682","kev_date_added":"2026-09-18","published":"2025-09-05"},{"cvss_score":9.8,"headline":"Mozilla Firefox Use-After-Free","id":"CVE-2024-9680","kev_date_added":"2024-10-15","published":"2024-10-09"},{"cvss_score":9.8,"headline":"RARLAB UnRAR Directory Traversal","id":"CVE-2022-30333","kev_date_added":"2022-08-09","published":"2022-05-09"},{"cvss_score":9.8,"headline":"Roundcube Webmail SQL Injection","id":"CVE-2021-44026","kev_date_added":"2023-06-22","published":"2021-11-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-04-23","vendors":["puma"]},"summary":"Attackers can access leaked information due to improper response body closure in Puma when used with Rails, requiring an upgrade to patched versions.","url":"https://insights.sbomify.com/CVE-2022-23634/"}