# CVE-2022-23634: Information Exposure when using Puma with Rails

> Attackers can access leaked information due to improper response body closure in Puma when used with Rails, requiring an upgrade to patched versions.

- **Severity:** High 8.0 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 11 Feb 2022
- **Updated:** 23 Apr 2025
- **Also known as:** DEBIAN-CVE-2022-23634, GHSA-rmj8-8hhh-gv5h, OESA-2024-1002, OESA-2024-1003, OESA-2024-1004, OESA-2024-1005, OESA-2024-1007, UBUNTU-CVE-2022-23634

## What is CVE-2022-23634?

CVE-2022-23634 is a high-severity vulnerability in Debian Debian Linux, published on 11 Feb 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Puma is a Ruby/Rack web server built for parallelism. Prior to `puma` version `5.6.2`, `puma` may not always call `close` on the response body. Rails, prior to version `7.0.2.2`, depended on the response body being closed in order for its `CurrentAttributes` implementation to work correctly. The combination of these two behaviors (Puma not closing the body + Rails' Executor implementation) causes information leakage. This problem is fixed in Puma versions 5.6.2 and 4.3.11. This problem is fixed in Rails versions 7.02.2, 6.1.4.6, 6.0.4.6, and 5.2.6.2. Upgrading to a patched Rails _or_ Puma version fixes the vulnerability.

Weakness: CWE-404 (Improper Resource Shutdown or Release), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2022-23634?

4 open source packages ship an affected version, including puma. It affects 4 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `puma` | RubyGems | All versions | 4.3.11 |
| `puma` | RubyGems | All versions | 4.3.11 |
| `puma` | RubyGems | From 5.0.0 | 5.6.2 |
| `puma` | RubyGems | From 5.0.0 | 5.6.2 |

Products: Debian Debian Linux, Fedoraproject Fedora, Puma Puma, Rubyonrails Rails.

## How do I fix CVE-2022-23634?

Upgrade puma to a fixed version for your release line: 4.3.11 or 5.6.2.

## Is CVE-2022-23634 being exploited?

There is no known exploitation of CVE-2022-23634 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-23634 and fix it if it is affected.

What it is: CVE-2022-23634 is a high-severity vulnerability in Debian Debian Linux, published on 11 Feb 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-23634 in the wild and no public exploit code.

Affected packages and fixed versions:
- puma (RubyGems): affected all versions; fixed in 4.3.11
- puma (RubyGems): affected all versions; fixed in 4.3.11
- puma (RubyGems): affected from 5.0.0; fixed in 5.6.2
- puma (RubyGems): affected from 5.0.0; fixed in 5.6.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-23634/ (Markdown: https://insights.sbomify.com/CVE-2022-23634/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-23634
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-23634
- OSV: https://osv.dev/vulnerability/CVE-2022-23634

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-23634/
Summaries are generated and may contain mistakes; the official description above is the record.
