# CVE-2022-23636: Invalid drop of partially-initialized instances in wasmtime

> Attackers can trigger invalid drops of uninitialized pointers in Wasmtime, potentially causing crashes or code execution, requiring specific configurations to exploit.

- **Severity:** Medium 5.1 (`CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Feb 2022
- **Updated:** 23 Apr 2025

## What is CVE-2022-23636?

CVE-2022-23636 is a medium-severity use after free vulnerability in bytecodealliance wasmtime, published on 16 Feb 2022. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Wasmtime is an open source runtime for WebAssembly & WASI. Prior to versions 0.34.1 and 0.33.1, there exists a bug in the pooling instance allocator in Wasmtime's runtime where a failure to instantiate an instance for a module that defines an `externref` global will result in an invalid drop of a `VMExternRef` via an uninitialized pointer. A number of conditions listed in the GitHub Security Advisory must be true in order for an instance to be vulnerable to this issue. Maintainers believe that the effective impact of this bug is relatively small because the usage of `externref` is still uncommon and without a resource limiter configured on the `Store`, which is not the default configuration, it is only possible to trigger the bug from an error returned by `mprotect` or `VirtualAlloc`. Note that on Linux with the `uffd` feature enabled, it is only possible to trigger the bug from a resource limiter as the call to `mprotect` is skipped. The bug has been fixed in 0.34.1 and 0.33.1 and users are encouraged to upgrade as soon as possible. If it is not possible to upgrade to version 0.34.1 or 0.33.1 of the `wasmtime` crate, it is recommend that support for the reference types proposal be disabled by passing `false` to `Config::wasm_reference_types`. Doing so will prevent modules that use `externref` from being loaded entirely.

Weakness: CWE-824 (Access of Uninitialized Pointer)

## Which versions are affected by CVE-2022-23636?

It affects 1 product.


Products: Bytecodealliance Wasmtime.

## How do I fix CVE-2022-23636?

Upgrade to a fixed version.

## Is CVE-2022-23636 being exploited?

There is no known exploitation of CVE-2022-23636 in the wild and no public exploit code.

Public exploit code:

- https://github.com/cyhe50/cve-2022-23636-poc (github_poc): https://github.com/cyhe50/cve-2022-23636-poc

## Other vulnerabilities in bytecodealliance wasmtime

- [CVE-2026-34971](https://insights.sbomify.com/CVE-2026-34971/): Wasmtime miscompiled guest heap access enables sandbox escape on aarch64 Cranelift (critical 9.0)
- [CVE-2026-34987](https://insights.sbomify.com/CVE-2026-34987/): Wasmtime with Winch compiler backend on aarch64 may allow a sandbox-escaping memory access (critical 9.0)
- [CVE-2022-39393](https://insights.sbomify.com/CVE-2022-39393/): Wasmtime vulnerable to data leakage between instances in the pooling allocator (high 8.6)
- [CVE-2022-24791](https://insights.sbomify.com/CVE-2022-24791/): Use after free in Wasmtime (high 8.1)
- [CVE-2026-47261](https://insights.sbomify.com/CVE-2026-47261/): Wasmtime: WASI path_open(TRUNCATE) bypasses `FilePerms::WRITE` host restriction (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-23636 and fix it if it is affected.

What it is: CVE-2022-23636 is a medium-severity use after free vulnerability in bytecodealliance wasmtime, published on 16 Feb 2022. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-23636 in the wild and no public exploit code.

Affected product: bytecodealliance wasmtime. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-23636/ (Markdown: https://insights.sbomify.com/CVE-2022-23636/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-23636
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-23636
- OSV: https://osv.dev/vulnerability/CVE-2022-23636

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-23636/
Summaries are generated and may contain mistakes; the official description above is the record.
