{"answers":{"affected":"2 open source packages ship an affected version, including enshrined/svg-sanitize. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-23638 in the wild and no public exploit code.","fix":"Upgrade enshrined/svg-sanitize to 0.15.0 or later.","what":"CVE-2022-23638 is a medium-severity cross-site scripting vulnerability in darylldoyle svg-sanitizer, published on 14 Feb 2022. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-23638 and fix it if it is affected.\n\nWhat it is: CVE-2022-23638 is a medium-severity cross-site scripting vulnerability in darylldoyle svg-sanitizer, published on 14 Feb 2022. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-23638 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- enshrined/svg-sanitize (Packagist): affected all versions; fixed in 0.15.0\n- enshrined/svg-sanitize (Packagist): affected all versions; fixed in 0.15.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-23638/ (Markdown: https://insights.sbomify.com/CVE-2022-23638/index.md)","id":"CVE-2022-23638","markdown":"https://insights.sbomify.com/CVE-2022-23638/index.md","name":"CVE-2022-23638","record":{"aliases":["GHSA-fqx8-v33p-4qcc","UBUNTU-CVE-2022-23638"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"PHP SVG sanitizer","requires_auth":"none","summary":"An attacker can inject malicious scripts via SVG files processed by the svg-sanitizer library, potentially executing code in the victim's browser.","user_interaction":"not_required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"svg-sanitizer","vendor":"svg-sanitizer_project"}],"cvss":{"score":6.2,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"svg-sanitizer is a SVG/XML sanitizer written in PHP. A cross-site scripting vulnerability impacts all users of the `svg-sanitizer` library prior to version 0.15.0. This issue is fixed in version 0.15.0. There is currently no workaround available.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cross-site Scripting in svg-sanitizer","id":"CVE-2022-23638","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2022"},"n_packages":2,"n_references":2,"next":{"headline":"Improper Restriction of Operations within the Bounds of a Memory Buffer and Race Condition in crossbeam-utils","id":"CVE-2022-23639"},"packages":[{"ecosystem":"Packagist","fixed":["0.15.0"],"introduced":["0"],"last_affected":[],"package":"enshrined/svg-sanitize","purl":null,"source":"GHSA-fqx8-v33p-4qcc"},{"ecosystem":"Packagist","fixed":["0.15.0"],"introduced":["0"],"last_affected":[],"package":"enshrined/svg-sanitize","purl":"pkg:composer/enshrined/svg-sanitize","source":"GHSA-fqx8-v33p-4qcc"}],"prev":{"headline":"Stored Cross-Site-Scripting (XSS) in Markdown Editor","id":"CVE-2022-23637"},"products":["svg-sanitizer"],"published":"2022-02-14","related":[{"cvss_score":7.5,"headline":"XSS in enshrined/svg-sanitize due to mishandled script and data values in attributes","id":"CVE-2019-18857","kev_date_added":null,"published":"2019-11-11"},{"cvss_score":6.1,"headline":"Sanitizer bypass in svg-sanitizer","id":"CVE-2019-10772","kev_date_added":null,"published":"2019-12-11"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-23","vendors":["darylldoyle"]},"summary":"An attacker can inject malicious scripts via SVG files processed by the svg-sanitizer library, potentially executing code in the victim's browser.","url":"https://insights.sbomify.com/CVE-2022-23638/"}