CVE-2022-23645 Out-of-bounds read in swtpm
An attacker can cause a denial of service in swtpm by providing a specially crafted state header, leading to a crash or startup failure.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Local or same network only
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-23645?
CVE-2022-23645 is a medium-severity denial of service vulnerability in Fedoraproject Fedora, published on 18 Feb 2022. It can only be exploited from the same machine or local network, with no action from the victim.
Official description
swtpm is a libtpms-based TPM emulator with socket, character device, and Linux CUSE interface. Versions prior to 0.5.3, 0.6.2, and 0.7.1 are vulnerable to out-of-bounds read. A specially crafted header of swtpm's state, where the blobheader's hdrsize indicator has an invalid value, may cause an out-of-bounds access when the byte array representing the state of the TPM is accessed. This will likely crash swtpm or prevent it from starting since the state cannot be understood. Users should upgrade to swtpm v0.5.3, v0.6.2, or v0.7.1 to receive a patch. There are currently no known workarounds.
Weakness: CWE-125
Which versions are affected by CVE-2022-23645?
It affects 3 products.
Linux distribution packages (14)
swtpm AlmaLinux:9 | All versions | 0.7.0-3.20211109gitb79fd91.el9 |
swtpm-libs AlmaLinux:9 | All versions | 0.7.0-3.20211109gitb79fd91.el9 |
swtpm-tools AlmaLinux:9 | All versions | 0.7.0-3.20211109gitb79fd91.el9 |
swtpm Red Hat:enterprise_linux:9::appstream | All versions | 0:0.7.0-3.20211109gitb79fd91.el9 |
swtpm-debuginfo Red Hat:enterprise_linux:9::appstream | All versions | 0:0.7.0-3.20211109gitb79fd91.el9 |
swtpm-debugsource Red Hat:enterprise_linux:9::appstream | All versions | 0:0.7.0-3.20211109gitb79fd91.el9 |
swtpm-libs Red Hat:enterprise_linux:9::appstream | All versions | 0:0.7.0-3.20211109gitb79fd91.el9 |
swtpm-libs-debuginfo Red Hat:enterprise_linux:9::appstream | All versions | 0:0.7.0-3.20211109gitb79fd91.el9 |
swtpm-tools Red Hat:enterprise_linux:9::appstream | All versions | 0:0.7.0-3.20211109gitb79fd91.el9 |
swtpm-tools-debuginfo Red Hat:enterprise_linux:9::appstream | All versions | 0:0.7.0-3.20211109gitb79fd91.el9 |
swtpm SUSE:Linux Enterprise Micro 5.1 | All versions | 0.5.3-150300.3.3.1 |
swtpm SUSE:Linux Enterprise Module for Server Applications 15 SP3 | All versions | 0.5.3-150300.3.3.1 |
swtpm openSUSE:Leap 15.3 | All versions | 0.5.3-150300.3.3.1 |
swtpm openSUSE:Tumbleweed | All versions | 0.7.1-1.1 |
Products include Fedoraproject Fedora, Redhat Enterprise Linux, Swtpm Project Swtpm.
How do I fix CVE-2022-23645?
Upgrade to a fixed version.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2022-23645 being exploited?
There is no known exploitation of CVE-2022-23645 in the wild and no public exploit code.
Other vulnerabilities in Fedoraproject Fedora
Sources
Also known as ALSA-2022:8100, DEBIAN-CVE-2022-23645, GHSA-2qgm-8xf4-3hqw, MGASA-2022-0112, OESA-2022-1576, OESA-2022-2049 and 3 more.