# CVE-2022-23645: Out-of-bounds read in swtpm

> An attacker can cause a denial of service in swtpm by providing a specially crafted state header, leading to a crash or startup failure.

- **Severity:** Medium 6.2 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Feb 2022
- **Updated:** 23 Apr 2025
- **Also known as:** ALSA-2022:8100, DEBIAN-CVE-2022-23645, GHSA-2qgm-8xf4-3hqw, MGASA-2022-0112, OESA-2022-1576, OESA-2022-2049, RHSA-2022:8100, SUSE-SU-2022:1297-1, openSUSE-SU-2024:11870-1

## What is CVE-2022-23645?

CVE-2022-23645 is a medium-severity denial of service vulnerability in Fedoraproject Fedora, published on 18 Feb 2022. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

swtpm is a libtpms-based TPM emulator with socket, character device, and Linux CUSE interface. Versions prior to 0.5.3, 0.6.2, and 0.7.1 are vulnerable to out-of-bounds read. A specially crafted header of swtpm's state, where the blobheader's hdrsize indicator has an invalid value, may cause an out-of-bounds access when the byte array representing the state of the TPM is accessed. This will likely crash swtpm or prevent it from starting since the state cannot be understood. Users should upgrade to swtpm v0.5.3, v0.6.2, or v0.7.1 to receive a patch. There are currently no known workarounds.

Weakness: CWE-125 (Out-of-bounds Read)

## Which versions are affected by CVE-2022-23645?

It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `swtpm` | AlmaLinux:9 | All versions | 0.7.0-3.20211109gitb79fd91.el9 |
| `swtpm-libs` | AlmaLinux:9 | All versions | 0.7.0-3.20211109gitb79fd91.el9 |
| `swtpm-tools` | AlmaLinux:9 | All versions | 0.7.0-3.20211109gitb79fd91.el9 |
| `swtpm` | Red Hat:enterprise_linux:9::appstream | All versions | 0:0.7.0-3.20211109gitb79fd91.el9 |
| `swtpm-debuginfo` | Red Hat:enterprise_linux:9::appstream | All versions | 0:0.7.0-3.20211109gitb79fd91.el9 |
| `swtpm-debugsource` | Red Hat:enterprise_linux:9::appstream | All versions | 0:0.7.0-3.20211109gitb79fd91.el9 |
| `swtpm-libs` | Red Hat:enterprise_linux:9::appstream | All versions | 0:0.7.0-3.20211109gitb79fd91.el9 |
| `swtpm-libs-debuginfo` | Red Hat:enterprise_linux:9::appstream | All versions | 0:0.7.0-3.20211109gitb79fd91.el9 |
| `swtpm-tools` | Red Hat:enterprise_linux:9::appstream | All versions | 0:0.7.0-3.20211109gitb79fd91.el9 |
| `swtpm-tools-debuginfo` | Red Hat:enterprise_linux:9::appstream | All versions | 0:0.7.0-3.20211109gitb79fd91.el9 |
| `swtpm` | SUSE:Linux Enterprise Micro 5.1 | All versions | 0.5.3-150300.3.3.1 |
| `swtpm` | SUSE:Linux Enterprise Module for Server Applications 15 SP3 | All versions | 0.5.3-150300.3.3.1 |
| `swtpm` | openSUSE:Leap 15.3 | All versions | 0.5.3-150300.3.3.1 |
| `swtpm` | openSUSE:Tumbleweed | All versions | 0.7.1-1.1 |

Products: Fedoraproject Fedora, Redhat Enterprise Linux, Swtpm Project Swtpm.

## How do I fix CVE-2022-23645?

Upgrade to a fixed version.

## Is CVE-2022-23645 being exploited?

There is no known exploitation of CVE-2022-23645 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-23645 and fix it if it is affected.

What it is: CVE-2022-23645 is a medium-severity denial of service vulnerability in Fedoraproject Fedora, published on 18 Feb 2022. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-23645 in the wild and no public exploit code.

Affected product: Fedoraproject Fedora. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-23645/ (Markdown: https://insights.sbomify.com/CVE-2022-23645/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-23645
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-23645
- OSV: https://osv.dev/vulnerability/CVE-2022-23645

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-23645/
Summaries are generated and may contain mistakes; the official description above is the record.
